Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66700 - [vulkan-validation-layers] Please consider offering unstripped binaries

Attached to Project: Arch Linux
Opened by mark r (io7m) - Monday, 18 May 2020, 19:34 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 18 June 2020, 13:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I recently encountered an issue whilst writing some Vulkan code that resulted in a crash inside the validation layers. This was a bug in _my_ code, not in the layers, but the only way that could be determined was because I went and compiled a debug version of the layers that had not had symbols stripped.

See: https://github.com/KhronosGroup/Vulkan-ValidationLayers/issues/1847

Given that the Vulkan validation layers are ostensibly a development tool, and given that stripping symbols demonstrably reduces their utility... Is there any chance you'd consider making an exception to the usual Arch policy of stripping libraries?

Additional info:
No extra info.

Steps to reproduce:
Introduce a bug in your code, and then try to use the validation layers to find it. :)
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 18 June 2020, 13:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  vulkan-validation-layers-1.2.140-2
Comment by And Moos (andmoos) - Wednesday, 27 May 2020, 12:59 GMT
+1 on this one having the same issue today.

> Given that the Vulkan validation layers are ostensibly a development tool, and given that stripping symbols demonstrably reduces their utility...
> Is there any chance you'd consider making an exception to the usual Arch policy of stripping libraries?
I would go further that without debug symbols the validation layers are of no real use to anyone developing a vulkan application, and indeed I can't think of any other usecase for them.
Comment by Laurent Carlier (lordheavy) - Saturday, 30 May 2020, 11:33 GMT
Please check vulkan-validation-layers-1.2.140-2 in testing
Comment by And Moos (andmoos) - Tuesday, 02 June 2020, 20:10 GMT
While the debug symbols didn't point me to the bug i was facing (segfault at unknown address) - it helped me digging into it.

FYI: When VK_LAYER_KHRONOS_validation is active in combination with nvidia-vulkan from AUR (had the issue with older drivers as well) loading vkGetImageMemoryRequirements2 via vkGetDeviceProcAddr returns a NULL - which the validation presumably tried to forward me to. Still, without the validation layer i get the correct function pointer. Loading the extension variant vkGetImageMemoryRequirements2KHR works either way...

I can work with that, thanks!

Loading...