Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#66696 - Don't ask "Replace X with Y" when using "--downloadonly"

Attached to Project: Pacman
Opened by kkl2401 (kkl2401) - Monday, 18 May 2020, 07:37 GMT
Last edited by Andrew Gregory (andrewgregory) - Tuesday, 19 May 2020, 19:52 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version 5.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

Very often (almost all the time) I use pacman in the following way: I run "pacman -Syuw" in order to download everything for an upgrade performed at a later time. It's slightly annoying (or perhaps unnecessary is a better word) to be asked whether I want to replace a package with another one, because I'm not about to perform the actual upgrade. I understand that this may be a useful information, so that I'm prepared for that replacement when I actually do the upgrade in the future but perhaps it could be just that: some sort of informative message instead of a question?


Steps to Reproduce:

Run "pacman -Syuw" when several packages have been replaced with different ones since the last upgrade.
This task depends upon

Closed by  Andrew Gregory (andrewgregory)
Tuesday, 19 May 2020, 19:52 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Look at pacinstall for skipping specific questions.
Comment by Andrew Gregory (andrewgregory) - Monday, 18 May 2020, 14:44 GMT
How should pacman know whether it needs to download the replacements if it doesn't ask? Just use --noconfirm.
Comment by kkl2401 (kkl2401) - Monday, 18 May 2020, 16:21 GMT
Fair point. I've never been in a situation when I wouldn't want to download the replacements but I guess other people might. Using --noconfirm seems too strong, since it's only these specific confirmations I'd like to avoid (and not others). Anyway, I take my request back because apparently there could be reasons not to download the replacements.

Loading...