Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66689 - [virtualbox-guest-utils] virtualbox graphic drivers broken

Attached to Project: Community Packages
Opened by Alexandre ZANNI (noraj) - Sunday, 17 May 2020, 15:20 GMT
Last edited by Christian Hesse (eworm) - Friday, 17 July 2020, 06:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

With last virtualbox-guest-utils update; virtualbox graphic drivers are borken.

The VM display is working during boot until DE load (KDE/plasma in my case) but a few second after the display goes black. vboxservice is still running and just before crashing I can see this 2 year old error message "vboxclient failed to register resizing support rc=verr invalid function". Of course I have xf86-video-vmware installed.

An interesting behavior is when I click on "Close the Virtual Machine" I can see the preview of what is displayed on the DE so the graphic drivers must not be totally crashed.

I have the same behavior with all 3 graphic drivers VboxVGA, VboxSVGA and VMSVGA.
I reproduced it on 2 different ArchLinux VM.


Maybe an important thing to mention is that I'm using EFI and so I have the "Enable EFI (special OSes only)" option checked.

Additional info:

* Linux 5.6.13
* virtualbox-guest-utils 6.1.18
* vboxservice.service active and running ok

Steps to reproduce:

* Install ArchLinux guest with last vanilla kernel and virtualbox-guest-utils in EFI mode.
* Select whatever graphic drivers VboxVGA, VboxSVGA and VMSVGA.
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 17 July 2020, 06:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox 6.1.12-1 and linux 5.7.9.arch1-1
Comment by Alexandre ZANNI (noraj) - Sunday, 17 May 2020, 15:20 GMT
I'm sorry I forgot to modify title.
Comment by Alexandre ZANNI (noraj) - Sunday, 17 May 2020, 15:32 GMT
Same behavior with fallback initramfs.
Same behavior with LTS kernel and virtualbox-guest-dkms.
Comment by Christian Hesse (eworm) - Monday, 18 May 2020, 06:47 GMT
Version 6.1.8-2 skips starting `VBoxClient --vmsvga-x11`. This should at least work around the issue.
Comment by Alexandre ZANNI (noraj) - Monday, 18 May 2020, 11:47 GMT Comment by TotallyNot Elite (TotallyNotElite) - Saturday, 11 July 2020, 18:24 GMT
Oh! I didn't see this issue. Proper fix is attached here: https://bugs.archlinux.org/task/67253
Comment by Christian Hesse (eworm) - Friday, 17 July 2020, 06:28 GMT
This should be fixed with virtualbox 6.1.12-1 and linux 5.7.9.arch1-1 (or linux-lts 5.4.52-1) when using VMSVGA.

Loading...