Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66681 - [telegram-desktop] User-defined fonts not working since last update (2.1.6)

Attached to Project: Community Packages
Opened by 3un0s (3un0s) - Sunday, 17 May 2020, 07:56 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 08 June 2020, 19:45 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Jiachen Yang (farseerfc)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: So since updating to 2.1.6 Telegram isn't using fonts set by me in the fontconfigs fonts.conf file and it's probably related to the new option introduced to the PKGBUILG in that update (-DDESKTOP_APP_USE_PACKAGED_FONTS=OFF). I'll try to build this package myself without that option and see if the user-defined fonts start to work again.


Additional info:
- package version: 2.1.6-1

Steps to reproduce: Update to the latest version of telegram-desktop
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 08 June 2020, 19:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  telegram-desktop 2.1.10-2
Comment by 3un0s (3un0s) - Sunday, 17 May 2020, 08:42 GMT
I can confirm that when compiling with -DDESKTOP_APP_USE_PACKAGED_FONTS=ON user-defined fonts work as expected.
Comment by slack3r (slack3r) - Wednesday, 20 May 2020, 08:54 GMT
Same here.

I can confirm that it's related to '+ -DDESKTOP_APP_USE_PACKAGED_FONTS=OFF'.
Comment by Amin Vakil (aminvakil) - Thursday, 04 June 2020, 14:43 GMT
Same here,
I have put IgnorePkg = telegram-desktop in my /etc/pacman.conf since then, why it has changed?
Comment by Amin Vakil (aminvakil) - Monday, 08 June 2020, 05:16 GMT
In latest update (2.1.10-2) -DDESKTOP_APP_USE_PACKAGED_FONTS=OFF has been removed.

https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/telegram-desktop&id=55a7e8aeee73ec7946bf094a1e50444f2f0a5873

I suppose this can be closed.

Loading...