Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66666 - mesa 20.0.7-1 causes segfault in GDM

Attached to Project: Arch Linux
Opened by Ben Wolsieffer (lopsided98) - Friday, 15 May 2020, 18:14 GMT
Last edited by freswa (frederik) - Thursday, 28 May 2020, 12:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Laurent Carlier (lordheavy)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description:

GDM fails to start after upgrading mesa from 20.0.6-2 to 20.0.7-1. It crashes with a segfault in Xwayland. See the attached file for a stack trace. Disabling Wayland in GDM results in a similar segfault in the gnome-shell process. Downgrading mesa fixes the problem.

Steps to reproduce:

1. Upgrade to mesa 20.0.7-1
2. Start GDM
This task depends upon

Closed by  freswa (frederik)
Thursday, 28 May 2020, 12:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  20.0.7-3
Comment by Cédric Schieli (sdrik) - Friday, 15 May 2020, 18:25 GMT
Same here.
Comment by Mika Attila (solvedsnake) - Friday, 15 May 2020, 18:27 GMT
I'm getting 'general protection fault' in radeonsi_dri.so when I launch chromium. I'm assuming this is the same error, because it disappears if I revert to 20.0.6.
Comment by Ben Wolsieffer (lopsided98) - Friday, 15 May 2020, 18:30 GMT
I should have mentioned that I am using an Intel GPU.
Comment by Christos Kotsaris (TemplarGR) - Friday, 15 May 2020, 18:32 GMT
I can confirm this, it not only affects GDM but it affects Plasma and GNOME as well when i switched to SDDM, it segfaults instantly. I use an AMD gpu, so i don't think it is vendor specific. Reverting just to mesa 20.0.6-2 fixes the issues
Comment by Laurent Carlier (lordheavy) - Friday, 15 May 2020, 18:39 GMT
I can reproduce the segfault too when building mesa 20.0.6 with gcc 10.1.0 - disabling lto seems to fix the issue
Comment by Laurent Carlier (lordheavy) - Friday, 15 May 2020, 18:46 GMT
Please test mesa-20.0.7-2
Comment by Cédric Schieli (sdrik) - Friday, 15 May 2020, 18:51 GMT
No more segfault with mesa-20.0.7-2 for me.
Comment by Ben Wolsieffer (lopsided98) - Friday, 15 May 2020, 18:57 GMT
Yes, 20.0.7-2 works, thanks.
Comment by Christos Kotsaris (TemplarGR) - Friday, 15 May 2020, 18:59 GMT
That's a pity LTO helps performance, let's hope upstream fixes this soon
Comment by eefano (eefano) - Friday, 15 May 2020, 19:04 GMT
PLEASE FIX lib32-mesa also!
otherwise Steam will crash.
Comment by Alexander Mezin (Sanya_M) - Thursday, 21 May 2020, 15:22 GMT
There is now a proper fix upstream: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/5104 As you can see from commit message, the issue may affect non-LTO build too
Comment by Christos Kotsaris (TemplarGR) - Friday, 22 May 2020, 13:05 GMT
This is nice, this means LTO can be re-enabled once the fixed version (whether 20.0.8 or 20.1.0) lands.
Comment by Florian Bruhin (The-Compiler) - Wednesday, 27 May 2020, 16:19 GMT
I see this has been reopened, but not sure why? Either way: I'm still getting crash reports in qutebrowser with a stacktrace pointing to this issue with 20.0.7-3. According to the reporter, it goes away when downgrading to -2 again: https://github.com/qutebrowser/qutebrowser/issues/5462

I can't reproduce it myself unfortunately, so I'm still trying to get a straightforward reproducer. But it looks like the upstream mesa fix is incomplete in some way.

Loading...