Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66636 - [cura] UI issues make Cura unusable on a fresh install

Attached to Project: Community Packages
Opened by Josh McCullough (joshm) - Wednesday, 13 May 2020, 01:58 GMT
Last edited by freswa (frederik) - Wednesday, 13 May 2020, 12:04 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

UI elements are messed up or missing. For instance, launching a fresh install of Cura will show the startup screen, but the buttons to continue/setup are not there at all. Also, if you can get past that, or have a working Cura config already (and therefore the startup screen is skipped), then the right sidebar where the print settings are has issues. The panel headers are often invisible (no text, no background, etc.). They can be clicked to expand/collapse the section, but it is unknown which section it is. Unfortunately I can't provide screenshots of the panel issue as I cannot get past the startup screen. I have installed the official build (4.6.1) and the UI is behaving correctly.

Additional info:
* package version: 4.5.0-1

Steps to reproduce:
* install Cura from AUR
* launch Cura and observe UI issues (missing buttons) -- see attachment for how it should look (4.6.1 installed from official package)
This task depends upon

Comment by Jelle van der Waa (jelly) - Wednesday, 13 May 2020, 18:57 GMT
Is this on KDE?
Comment by Josh McCullough (joshm) - Monday, 18 May 2020, 14:28 GMT
Sorry, yes ...

Operating System: Manjaro Linux
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.2
Kernel Version: 5.6.11-1-MANJARO
OS Type: 64-bit
Comment by Andi (And1G) - Thursday, 02 July 2020, 22:31 GMT
Cura on Arch is not directly a joy to use.

I am using this script to launch Cura which minimizes the UI issues to a minimum:
#!/usr/bin/env sh
export QT_QUICK_CONTROLS_STYLE=material
export QT_SCALE_FACTOR=1
export QT_AUTO_SCREEN_SCALE_FACTOR=0
export QT_SCREEN_SCALE_FACTORS=""
/usr/bin/cura "${@}"

Unfortunately the default cura.desktop contains the full path in the Exec key, so there is no easy override by putting the script in /usr/local/bin...

Sadly, this does not fix your issue but it might do as a workaround. QT_QUICK_CONTROLS_STYLE fixes the startup screen, the other variables fix the very garbled layout if you scale your screen globally.
Comment by Josh McCullough (joshm) - Friday, 03 July 2020, 11:27 GMT
Thanks, I'll give it a try and report back.

Loading...