Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66608 - [bemenu] 0.4.0-1: Invisible Menu With Wayland Compositor

Attached to Project: Community Packages
Opened by arl (Nestor) - Monday, 11 May 2020, 09:21 GMT
Last edited by Ivy Foster (escondida) - Monday, 18 May 2020, 22:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ivy Foster (escondida)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Menu works but is invisible with wayland compositor sway.


Steps to reproduce:

Use sway compositor
Upgrade bemenu from 0.3.0-3 to 0.4.0-1 and install bemenu-wlroots 0.4.0-1: Menu works but is invisible
Downgrade to 0.3.0-3: Works fine


This task depends upon

Closed by  Ivy Foster (escondida)
Monday, 18 May 2020, 22:44 GMT
Reason for closing:  Works for me
Additional comments about closing:  I can't reproduce, both reporting users have chimed in to say it works now.
Comment by Ivy Foster (escondida) - Tuesday, 12 May 2020, 00:30 GMT
I can't reproduce this; I finally got sway running (don't get me started on Wayland...), and bemenu shows up just fine. Can you be more specific about the steps to reproduce?
Comment by Jules Sam Randolph (jsamr) - Tuesday, 12 May 2020, 11:10 GMT
I have the same issue on x11 after upgrading to 0.4.0-1.
So I have bemenu and bemenu-x11 installed.
Running bemenu-run from the terminal doesn't show anything, neither in the terminal nor in X11 and exits with 1 status.

Could also reproduce with bemenu-ncurses
Comment by Ivy Foster (escondida) - Tuesday, 12 May 2020, 19:17 GMT
Hrm. The X11 one I use every day, and can't reproduce, and I also just tested bemenu-ncurses again (I tested all three before the update), and it worked fine. I've also attempted running each renderer with the other renderers uninstalled, tried installing fresh...I just can't reproduce this.
Comment by arl (Nestor) - Wednesday, 13 May 2020, 15:23 GMT
Thanks for the fast response. I just tried again and I have to excuse myself.

The menu is not invisible, I just didn't see it because it is only displayed on the last output of which I have three.
Even if this output is switched off (as it was when I tried) it is not displayed on an active output.

The new question is:
How to assign the menu to a specific output or have it displayed on all outputs (that is the v 0.3. behaviour)?

Thanks for your help.
Comment by arl (Nestor) - Friday, 15 May 2020, 10:34 GMT
My fault, just a new otption that came with the update:

Use bemenu-run -m all.


Sorry, my mistake.
Comment by Jules Sam Randolph (jsamr) - Monday, 18 May 2020, 13:38 GMT
@escondida I have not been able to reproduce the issue after trying again today. I don't know which circumstances made it fail last time, but I think you can safely consider this resolved.
Comment by Ivy Foster (escondida) - Monday, 18 May 2020, 22:43 GMT
Well, fair enough! That's both responders, then. I guess I'll go ahead and close it.

Loading...