Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66605 - [lensfun] NULL dereference; breaking gimp-nufraw

Attached to Project: Arch Linux
Opened by mpan (mpan) - Sunday, 10 May 2020, 17:57 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 16 May 2020, 10:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
A `NULL` pointer dereference[1] causes a segfault. Most likely the cause of  FS#66319 , which is also the reason this bug is opened also on Arch bugtracker.

Version: 0.3.95-1

Steps to reproduce:
While:
- Used with `nufraw something.CR2` (where .CR2 is a Canon RAW);
- Used to open a CR2 otherwise;
- Used with nufraw executed from Gimp with a CR2;
segfaults. With debug symbols available the backtrace is:
---------------------------------------------------------------
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7ab9b5d in lfLens::operator= (this=this@entry=0x55555590e838, other=...)
at /usr/src/debug/lensfun-0.3.95/libs/lensfun/lens.cpp:99
99 /usr/src/debug/lensfun-0.3.95/libs/lensfun/lens.cpp: No such file or directory.
(gdb) bt
#0 0x00007ffff7ab9b5d in lfLens::operator=(lfLens const&) (this=this@entry=0x55555590e838, other=...)
at /usr/src/debug/lensfun-0.3.95/libs/lensfun/lens.cpp:99
#1 0x000055555562459b in nUFRaw::Lensfun::SetLensInterpolation() (this=0x55555590e800) at nufraw_lensfun.cc:717
#2 0x0000555555625297 in nUFRaw::Lensfun::SetCamera(lfCamera const&) (camera=..., this=0x55555590e800) at nufraw_lensfun.cc:93
#3 nUFRaw::Lensfun::Init(bool) (this=0x55555590e800, reset=reset@entry=true) at nufraw_lensfun.cc:781
#4 0x000055555562567f in nUFRaw::nufraw_lensfun_init(UFObject*, UFBoolean) (lensfun=<optimized out>, reset=reset@entry=1) at nufraw_lensfun.cc:849
#5 0x000055555560c80f in nufraw_config (uf=0x555555927000, rc=<optimized out>, conf=0x7ffffffe0590, cmd=<optimized out>) at nufraw_interface.c:502
#6 0x000055555560393c in main (argc=<optimized out>, argv=<optimized out>) at nufraw_main.c:127
---------------------------------------------------------------

No RAW small enough to attach is available.

The current workaround, causing a partial upgrade, seems to be downgrading to 0.3.2-9 with the relevant downgrades for gimp-nufraw and cfitsio.

____
[1] https://github.com/lensfun/lensfun/issues/1132
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 16 May 2020, 10:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  lensfun 0.3.95-2

Loading...