Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66595 - [fontconfig] fontconfig scans /etc/fonts/conf.avail directory

Attached to Project: Arch Linux
Opened by Pavel Lutskov (ltskv) - Saturday, 09 May 2020, 14:18 GMT
Last edited by freswa (frederik) - Saturday, 09 May 2020, 14:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

According to the FC_DEBUG output (see below),
after the `/etc/fonts/conf.d directory` is scanned,
the /etc/fonts/conf.avail directory gets scanned,
which is not the correct behavior.

Additional info:
* fontconfig version 2:2.13.91+24+g75eadca-2
* Example output (with the list of scanned files collapsed into `...`):

```
$ FC_DEBUG=1024 gvim
FC_DEBUG=1024
Loading config file from /etc/fonts/fonts.conf
Scanning config dir /etc/fonts/conf.d
Loading config file from /etc/fonts/conf.d/10-hinting-slight.conf
...
Loading config file from /etc/fonts/conf.d/90-synthetic.conf done
Loading config file from /etc/fonts/fonts.conf done
Scanning config dir /etc/fonts/conf.avail
...
Scanning config file from /etc/fonts/conf.avail/70-yes-bitmaps.conf done
```

It's noteworthy that not all of the files in `conf.avail` are scanned, with the files
`80-delicious.conf` and `90-synthetic.conf` not being reported as scanned.

Steps to reproduce: run an application that uses fontconfig with FC_DEBUG environment
variable?

This task depends upon

Closed by  freswa (frederik)
Saturday, 09 May 2020, 14:49 GMT
Reason for closing:  Not a bug
Comment by Pavel Lutskov (ltskv) - Saturday, 09 May 2020, 14:48 GMT
My bad, I checked again, and it's __scanning__ and not __loading__ the conf.avail,
which I think is not unexpected or undesired.

Loading...