Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66582 - [gnome-documents] Libreoffice integration does not work

Attached to Project: Arch Linux
Opened by Marcus Behrendt (mareex) - Thursday, 07 May 2020, 20:23 GMT
Last edited by freswa (frederik) - Thursday, 07 May 2020, 22:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
libreoffice-fresh is listed as a optdepend but if one tries to open a document a error message is shown.
Roughly translated it says "Oops! Libreoffice support is not available. Please contact your system administrator"

I also tried to install libreoffice-fresh-sdk, but to no avail. Something seems to be broken

Additional info:
* gnome-documents: 3.34.0+6+g966b04ec-1
* libreoffice: 6.4.3-3

What occurs in journalctl -f
```
JS ERROR: Unable to load document: Gio.IOErrorEnum: Internal error: LibreOffice isn't available
loadLocal@resource:///org/gnome/Documents/js/documents.js:694:29
load/<@resource:///org/gnome/Documents/js/documents.js:416:18
downloadImpl/</<@resource:///org/gnome/Documents/js/documents.js:1144:17
replaceFile/</<@resource:///org/gnome/Documents/js/utils.js:179:21
main@resource:///org/gnome/Documents/js/main.js:47:24
run@resource:///org/gnome/gjs/modules/script/package.js:222:19
@/usr/bin/gnome-documents:6:17
```

Steps to reproduce:
Start gnome-documents and click on a libreoffice file. Then the mentioned error pops up.
This task depends upon

Comment by Srikanth (M.Srikanth) - Saturday, 12 September 2020, 08:26 GMT Comment by mattia (nTia89) - Sunday, 20 March 2022, 13:21 GMT
Currently `gnome-documents` is no more maintained
("Archived" state in GNOME's gitlab)
furthermore it does not work anymore (segmentation fault).

I should think if keep this issue open (as well as keep `gnome-documents` in our repo... as well as its deprecated dependencies)

Loading...