Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66560 - [Libvirt 6.3.0] VirtManager cannot load '/usr/lib/libvirt/storage-file/libvirt_storage_file_fs.so'

Attached to Project: Community Packages
Opened by Frederic Bezies (fredbezies) - Wednesday, 06 May 2020, 12:39 GMT
Last edited by Robin Broda (coderobe) - Wednesday, 06 May 2020, 14:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Rebischke (Shibumi)
Robin Broda (coderobe)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When I try to launch a VM in virt-manager after upgrading libvirt to version 6.3.0, I got an error telling me it was not able to load '/usr/lib/libvirt/storage-file/libvirt_storage_file_fs.so'

Additional info:
libvirt: 6.3.0-1
virt-manager: 2.2.1-2

Steps to reproduce:

1) Have a working VirtManager installation
2) Update libvirt to version 6.3.0
3) Try to launch a VM

Error log:

```
Error starting domain: internal error: Failed to load module '/usr/lib/libvirt/storage-file/libvirt_storage_file_fs.so': /usr/lib/libvirt.so.0: version `LIBVIRT_PRIVATE_6.3.0' not found (required by /usr/lib/libvirt/storage-file/libvirt_storage_file_fs.so)

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 75, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 111, in tmpcb
callback(*args, **kwargs)
File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 66, in newfn
ret = fn(self, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/object/domain.py", line 1279, in startup
self._backend.create()
File "/usr/lib/python3.8/site-packages/libvirt.py", line 1152, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
```
This task depends upon

Closed by  Robin Broda (coderobe)
Wednesday, 06 May 2020, 14:13 GMT
Reason for closing:  Works for me
Additional comments about closing:  cannot reproduce
Comment by Doug Newgard (Scimmia) - Wednesday, 06 May 2020, 13:54 GMT
Except /usr/lib/libvirt.so.0 does define LIBVIRT_PRIVATE_6.3.0
Comment by Robin Broda (coderobe) - Wednesday, 06 May 2020, 14:12 GMT
Works on my machine.

Loading...