Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66559 - [keybase-gui] opening links seems to be broken

Attached to Project: Community Packages
Opened by Daniel Martí (mvdan) - Wednesday, 06 May 2020, 11:51 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 06 May 2020, 21:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Eli Schwartz (eschwartz)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I raised this bug upstream at https://github.com/keybase/client/issues/23198. It doesn't seem like anyone else is seeing this problem, so I'm starting to think that it's a problem with how Arch packages the keybase GUI.

Additional info:
* package version(s): keybase-gui 5.4.2-1, electron 8.2.5-1
* config and/or log files etc: logged into two keybase accounts at once.
* link to upstream bug report, if any: https://github.com/keybase/client/issues/23198

Steps to reproduce:

Click on any link in a message in the keybase GUI. It doesn't open a browser or anything.

If you're running keybase-gui manually via a terminal, you'll see output like:

> Mar 23 15:02:01 carbon electron[75612]: could not find program for '68', check your configuration
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 06 May 2020, 21:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  caused by an xdg-open replacement that doesn't seem to be handling things the way xdg-open would
Comment by Eli Schwartz (eschwartz) - Wednesday, 06 May 2020, 14:07 GMT
This "just works" for me, both when started as a systemd user service and when starting in the foreground directly as `electron /usr/share/keybase-app`. I lack knowledge of what that error message might indicate.
Comment by Daniel Martí (mvdan) - Wednesday, 06 May 2020, 14:21 GMT
Huh, so it really is just me. I'll dig a bit more and see what I can find. I think it's worth leaving this bug open for a bit, to see if other Arch users see the same or not.
Comment by Daniel Martí (mvdan) - Wednesday, 06 May 2020, 15:01 GMT
I dug some more, and ended up finding that the cause of the breakage was having installed an xdg-utils alternative, linopen from the AUR.

Replacing it with xdg-utils again fixes opening links.

Given that linopen is not an official package in the repositories, I think this issue can be closed. It might still be worth investigating why a standalone xdg-open tool isn't enough to open links with keybase, since that's enough with lots of other link-opening programs. But that's more of an enhancement for upstream.
Comment by Eli Schwartz (eschwartz) - Wednesday, 06 May 2020, 21:42 GMT
You could try adding debug traces to linopen and see what it's doing, I suppose (e.g. what are the arguments it is parsing immediately upon entering the script). But yeah, best to discuss it with upstream as it seems to be a generalized issue with this xdg-open replacement.

Loading...