Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66551 - [cockpit] Manage 389 Directory Server

Attached to Project: Community Packages
Opened by Jameson Pugh (ImNtReal) - Tuesday, 05 May 2020, 17:04 GMT
Last edited by freswa (frederik) - Thursday, 07 May 2020, 22:27 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Massimiliano Torromeo (mtorromeo)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Can't manage 389 Directory Server via Cockpit

See https://bugs.archlinux.org/task/66363


Additional info:
* 389-ds-base 1.4.3.4-2
* cockpit 217-1
~ sudo pkcon search 389-ds-base 5.9s  Thu 23 Apr 2020 01:44:03 PM EDT
Searching by details [=========================]
Finished [=========================]
Installed 389-ds-base-1.4.3.4-2.x86_64 (installed) 389 Directory Server (base)

Steps to reproduce:

Despite PackageKit showing 389-ds-base being installed, when I log in to Cockpit, and click the 389 Directory Server tab, I get a message that says:
There is no 389-ds-base package installed on this system. Sorry there is nothing to manage...

If I attempt to install 389-ds-base via Cockpit, I get a message stating:
Error installed/389-ds-base: could not find database

I have even removed the package via pacman, and re-installed it from the Cockpit interface. It appears to have installed the package, but still shows the Install button for it, and I still can't manage it.

I'm not sure if this is a problem with the 389-ds-base package, the cockpit package, or something with my config. I'm definitely willing to help collect more information, and debug. Please, let me know steps to troubleshoot this issue.
This task depends upon

Closed by  freswa (frederik)
Thursday, 07 May 2020, 22:27 GMT
Reason for closing:  Upstream
Additional comments about closing:  https://github.com/cockpit-project/cockp it/issues/14034
Comment by Jameson Pugh (ImNtReal) - Tuesday, 05 May 2020, 17:21 GMT Comment by Jameson Pugh (ImNtReal) - Thursday, 07 May 2020, 20:50 GMT
It looks like upstream closed their issue stating that it wasn't their code, so I'm going to request this be closed. I have another issue with Cockpit not correctly detecting that 389-ds-base is installed, but I can open a different issue for that I don't get it resolved with the 389 Directory Server people.

Loading...