Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66550 - [chromium] web browser does not detect microphone in Google Meet Sessions

Attached to Project: Arch Linux
Opened by Antonio Corbi bellot (acorbi) - Tuesday, 05 May 2020, 16:25 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 06 May 2020, 07:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Trying to hold a Google Meet Session with chromium version 81.0.4044.129-2 it says it can detect my mic and that I don't have plugged-in one. That's no true because I've one and i.e I can record sound with Audacity.

I've tried with current versions of google-chrome (81.0.4044.129-1) and brave-bin (1:1.8.86-1) from the AUR and they behave the same as chromium.

Additional info:
* package version(s)

chromium version 81.0.4044.129-2

Steps to reproduce:

Connect with chromium to my google drive account, try to connect to a google meet session and it says it can detect no mic.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 06 May 2020, 07:57 GMT
Reason for closing:  Works for me
Comment by Evangelos Foutras (foutrelis) - Wednesday, 06 May 2020, 06:05 GMT
Seems to work for me. Maybe check pavucontrol to see if the correct input is selected and marked as default. Also review the microphone settings in Meet by clicking on the gear icon.
Comment by Antonio Corbi bellot (acorbi) - Wednesday, 06 May 2020, 07:26 GMT
Hi Evangelos,

I've just updated chromium to version 81.0.4044.138-1 and it seems to work now.

Yesterday I reported also " FS#66549 : [firefox] 76.0-1 problems with sound input from microphone", firefox has been updated today and it also works.

The bug was different in both browsers (firefox detected the mic but did not streamed the sound) and now both of them are working...don't know if it is related somehow...

Anyway, thanks for the quick response!
Comment by Evangelos Foutras (foutrelis) - Wednesday, 06 May 2020, 07:57 GMT
Firefox seemed to have broken WebRTC when built against NSS 3.52. The Chromium issue might have been related to input selection.

Glad both browsers work for you now. :) -- Do check pavucontrol and Meet's settings if it happens again.

Loading...