Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66507 - [inkscape] Compiled against an outdated poppler version

Attached to Project: Arch Linux
Opened by Martin Roth (Captain_Rage) - Saturday, 02 May 2020, 08:59 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 02 May 2020, 10:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Gaetan Bisson (vesath)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

When starting inkscape 1.0-1 this message is displayed and the program doesn't start:

inkscape: error while loading shared libraries: libpoppler.so.98: cannot open shared object file: No such file or directory

although poppler is installed (the current version seems to be libpoppler.so.99).
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 02 May 2020, 10:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  inkscape 1.0-2
Comment by Olav Seyfarth (nursoda) - Saturday, 02 May 2020, 09:09 GMT
Severity: Low? Inkscape no longer starts after the upgrade to 1.0-1 …
Comment by Georg Mayr (georgm) - Saturday, 02 May 2020, 09:26 GMT
Severity: high
Comment by Evangelos Foutras (foutrelis) - Saturday, 02 May 2020, 10:34 GMT
Looks like inkscape 1.0-1 was built just before I moved poppler to extra; unlucky timing!

Pushing a rebuilt package now.

Loading...