Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66478 - [autorandr] systemd hook no longer triggers autorandr

Attached to Project: Community Packages
Opened by Marco Vermeulen (marc0der) - Thursday, 30 April 2020, 13:29 GMT
Last edited by freswa (frederik) - Thursday, 30 April 2020, 14:17 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Prior to upgrading to 1.10-1, autorandr would be triggered automatically by systemd to change to its detected profile.
This worked seamlessly until the last upgrade, where the systemd hook no longer seems to be registered anymore.

Autorandr itself still works fine and changes layout when issuing `autorandr --change` from the command line,
but no longer does this automatically when a monitor is plugged in.


Additional info:

* package version(s)

1.10-1

* config and/or log files etc.

autorandr 1.9-1 logged the following when plugging in a new monitor:

Apr 30 12:25:21 rocinante systemd[1]: Starting autorandr execution hook...
Apr 30 12:25:22 rocinante autorandr[1461332]: Image already converted, doing nothing...
Apr 30 12:25:22 rocinante autorandr[1461325]: autorandr running as user marco (started from batch instance)
Apr 30 12:25:22 rocinante autorandr[1461325]: multi (detected)
Apr 30 12:25:22 rocinante autorandr[1461325]: work
Apr 30 12:25:22 rocinante autorandr[1461325]: hdmi
Apr 30 12:25:22 rocinante autorandr[1461325]: single
Apr 30 12:25:22 rocinante autorandr[1461325]: laptop
Apr 30 12:25:22 rocinante autorandr[1461322]: Running autorandr as marco for display :0
Apr 30 12:25:22 rocinante systemd[1]: autorandr.service: Succeeded.
Apr 30 12:25:22 rocinante systemd[1]: Started autorandr execution hook.


autorandr 1.10-1 does not log anything at all

* link to upstream bug report, if any

N/A

Steps to reproduce:

1. Upgrade to 1.10-1
2. autorandr systemd hook no longer works
This task depends upon

Closed by  freswa (frederik)
Thursday, 30 April 2020, 14:17 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Upstream decision
Comment by Doug Newgard (Scimmia) - Thursday, 30 April 2020, 13:43 GMT
Seems like this was an upstream decision: https://github.com/phillipberndt/autorandr/commit/e1c85639c3dbcfe86a7003bc916efafe629bcbf9

Does your WM/DE ignore xdg autostart?
Comment by Marco Vermeulen (marc0der) - Thursday, 30 April 2020, 13:57 GMT
Thanks for replying about this.

I'm using i3wm and it doesn't seem to honour the autostart files provided by the package.
I suspect this will be true for many other lightweight window managers too.
I'm guessing since this is an upstream decision there is nothing much to be done about it.

Loading...