Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66362 - linux 5.6.6.arch1-1 missing ahci and libahci modules

Attached to Project: Arch Linux
Opened by Andrius V (vezhlys) - Thursday, 23 April 2020, 16:20 GMT
Last edited by freswa (frederik) - Thursday, 23 April 2020, 16:52 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since my upgrade from 5.5.10 to 5.6.3 linux kernel my system stopped booting. Eventually I identified an issue: ahci module is missing in the package (ahci.ko.xz, libahci.ko.xz in /kernel/drivers/ata/). My SATA controller depends on ahci module to work properly. I believe they are missing by mistake? The issue persists in the latest package as of today (5.6.6.arch1-1), including testing one 5.6.7.arch1-1 (by looking at list of files).

Additional info:
* package version 5.6.6.arch1-1

Steps to reproduce:
Check for missing kernel modules in /kernel/drivers/ata/.
This task depends upon

Closed by  freswa (frederik)
Thursday, 23 April 2020, 16:52 GMT
Reason for closing:  Not a bug
Additional comments about closing:  ahci and libahci are built-in

Loading...