Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66332 - Terminator 1.92-1: Missing dependency python-configobj

Attached to Project: Community Packages
Opened by Tobias Borgert (Blutkoete) - Tuesday, 21 April 2020, 06:21 GMT
Last edited by freswa (frederik) - Tuesday, 21 April 2020, 10:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

terminator 1.92-1 has a dependency on python-configobj which is not satisfied by its PKGBUILD, resulting in terminator not starting after the update, complaining about a missing configobj module during startup.

Workaround: Manually install python-configobj.

Additional info:
* terminator 1.92-1

Steps to reproduce:
* Uninstall python-configobj if present on your computer. This will not affect terminator's installation as python-configobj is not an official dependency.
* Launch terminator.
This task depends upon

Closed by  freswa (frederik)
Tuesday, 21 April 2020, 10:55 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#66329 
Comment by Ben (root) - Tuesday, 21 April 2020, 06:57 GMT
Confirmed. Terminator failed after upgrading from 1.91-6 to 1.92-1. After installing python-configobj it worked again.
Comment by Bartosz Sewera (Barteks88) - Tuesday, 21 April 2020, 07:51 GMT
Confirmed. Terminator does not start after update. Installing python-configobj solved problem.
Comment by Marvin (caliberspoon) - Tuesday, 21 April 2020, 09:03 GMT
Confirmed. Terminator doesn't start after the latest update. Works after installing python-configobj.
Comment by Cyril (cqknard) - Tuesday, 21 April 2020, 09:27 GMT
Confirmed, same issue, same solution : install python-configobj

$ terminator
Traceback (most recent call last):
File "/usr/bin/terminator", line 48, in <module>
import terminatorlib.optionparse
File "/usr/lib/python3.8/site-packages/terminatorlib/optionparse.py", line 24, in <module>
from . import config
File "/usr/lib/python3.8/site-packages/terminatorlib/config.py", line 75, in <module>
from configobj import ConfigObj, flatten_errors
ModuleNotFoundError: No module named 'configobj'

Package "python-configobj" must be a required depedency.

Loading...