Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66329 - [terminator] should depend on python-configobj

Attached to Project: Community Packages
Opened by Hoot (drountian) - Monday, 20 April 2020, 21:15 GMT
Last edited by Giancarlo Razzolini (grazzolini) - Wednesday, 22 April 2020, 17:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Giancarlo Razzolini (grazzolini)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 19
Private No

Details

Description:

Additional info:
* package version(s)
broken: terminator 1.92-1
works: terminator 1.91-6

* config and/or log files etc.
I do NOT have python-configobj (or python2-configobj) installed

* my best guess as to why this is happening:
In the upstream repo the included configobj library is removed in a3a673,
but the python-configobj package is not marked as a dependency for the new 1.92-1 arch package.

* note:
I did not report this upstream because I believe the idea is for configobj to henceforth be a dependency
of terminator, this should probably be handled in the arch package system?

Steps to reproduce:
1. Make sure that python-configobj is NOT installed
2. Install terminator 1.92-1 via pacman
3. Try to run terminator, it crashes because it cannot find configobj

Steps to fix:
1. Install the python-configobj package
2. Run terminator, fixed
This task depends upon

Closed by  Giancarlo Razzolini (grazzolini)
Wednesday, 22 April 2020, 17:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  terminator-1.92-2 adds python-configobj as a dependency.
Comment by Stephane Gagne (smg3d) - Tuesday, 21 April 2020, 02:13 GMT
$ terminator
Traceback (most recent call last):
File "/usr/bin/terminator", line 48, in <module>
import terminatorlib.optionparse
File "/usr/lib/python3.8/site-packages/terminatorlib/optionparse.py", line 24, in <module>
from . import config
File "/usr/lib/python3.8/site-packages/terminatorlib/config.py", line 75, in <module>
from configobj import ConfigObj, flatten_errors
ModuleNotFoundError: No module named 'configobj'


And as mentioned above, installing (community/python-configobj 5.0.6-7) fixes the missing dependency.
Comment by Troy Engel (TE) - Tuesday, 21 April 2020, 19:32 GMT
Another confirmation after upgrading today, we now require `python-configobj` to be added as a hard dependency as part of the new python3 update; it's outlined in the upstream INSTALL file for us. https://github.com/gnome-terminator/terminator/blob/master/INSTALL
Comment by jstjohn (jstjohn) - Tuesday, 21 April 2020, 21:09 GMT
Installing python-configobj also fixes this problem for me.
Comment by Fikri Muhammad Iqbal (fikrimi) - Wednesday, 22 April 2020, 00:41 GMT
confirmed for python-configobj fix
Comment by Freddy (AvelVras) - Wednesday, 22 April 2020, 10:21 GMT
Hello,
python-configobj solved pb too.
Thanks
Comment by Antonio Cleverson (cleversonc6) - Wednesday, 22 April 2020, 11:22 GMT
Hi,
install `python-configobj` resolved problem.
Thanks!

Loading...