Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66319 - [gimp-nufraw] crash, Segmentation fault

Attached to Project: Community Packages
Opened by Krischan (Neutrino) - Sunday, 19 April 2020, 22:33 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 16 May 2020, 11:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
gimp-nufraw 0.43.3-1 is not working at my PC (AMD CPU&GPU) and Laptop (Intel CPU&GPU). nufraw crashes by opening a raw image and doesn't show a window, also don't work in gimp. In commandline I only get "Segmentation fault (core dumped)"
Even with lensfun-git it is not working. I had to downgrade gimp-nufraw 0.43.3-1 to 0.42-5 and lensfun 0.3.95 to 0.3.2-9 to work.

Additional info:
* Operating System: Arch Linux; KDE Plasma Version: 5.18.4; KDE Frameworks Version: 5.69.0; Qt Version: 5.14.2; Kernel Version: 5.6.4-arch1-1; OS Type: 64-bit; AMDGPU RX5700
* aur/nufraw 0.43_3-1 was also not working

Steps to reproduce:
starting nufraw /home/$user/pics/somepic.CR2
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 16 May 2020, 11:55 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#66605 
Comment by Krischan (Neutrino) - Monday, 20 April 2020, 00:06 GMT
(edited): ok, it seems to be a problem from nufraw, Nigel J. Terry reported probably same issue here: https://sourceforge.net/p/nufraw/discussion/bugs/thread/792a8993a1/#1928 but I opened a new thread for this issue: "nUFRaw 0.43.3 CRASHES at opening certain raw images" https://sourceforge.net/p/nufraw/discussion/bugs/thread/f4a006a8ba/
Comment by Krischan (Neutrino) - Monday, 20 April 2020, 23:14 GMT
to localize the error: nufraw 0.43.3 crashes with ~.CR2 and ~.DNG files (from Canon 400D (likely 400plus firmware) or IXUS40 (via CHDK Firmware))
but not with ~.DNG files (from FC300X Camera) or ~.CRW file (from Canon PowerShot A620)
Comment by Krischan (Neutrino) - Saturday, 25 April 2020, 11:25 GMT
developer "matteo lucarelli" said:
"On my system nufraw opens both images flawless..

Maybe is a distribution-related problem"
Comment by mattia (nTia89) - Sunday, 03 May 2020, 07:49 GMT
I confirm: the issue with some RAW file like:

$ nufraw RAW_CANON_EOS70D.CR2
Segmentation fault (core dumped)

while with other it works:

$ nufraw sony_a7_iii_15.arw
Comment by Marcin Andrzejewski (mpan) - Sunday, 10 May 2020, 18:19 GMT
Possibly caused by  FS#66605 .

Can you reproduce while building with debug symbols enabled and see if the backtrace is the same?

Loading...