Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66305 - [linux] [linux-lts] Shutdown and reboot are broken on AMD Ryzen3

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Sunday, 19 April 2020, 06:34 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 19 April 2020, 15:03 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: I noticed since I updated to both Linux 5.6.5 and 5.4.33 LTS that I cannot get it to shutdown correctly and or reboot correctly.

Looking at kernel's bugzilla, I found this issue: https://bugzilla.kernel.org/show_bug.cgi?id=207331 and this patch: https://bugzilla.kernel.org/show_bug.cgi?id=207331

I did not build last short term kernel against it right now, but I'll try and report.

Additional info:
linux 5.6.5.arch2-1
linux-lts 5.4.33-2

Steps to reproduce:

Just upgrade on a Ryzen3 installation your kernel, both lts and not-lts. Try to shut it down.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 19 April 2020, 15:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.6.5.arch3-1
linux-lts 5.4.33-3
Comment by Frederic Bezies (fredbezies) - Sunday, 19 April 2020, 06:41 GMT
Downgraded lts kernel to 5.4.32-1 and shutdown worked flawlessly. Will build a patched linux kernel 5.6.5 and report.

Wrong url for patch! Good one: https://cgit.freedesktop.org/~agd5f/linux/commit/?h=drm-fixes-5.7&id=b2a7e9735ab2864330be9d00d7f38c961c28de5d

EDIT: shutdown and reboot are working back again with this patch added to PKGBUILD.
Comment by AK (Andreaskem) - Sunday, 19 April 2020, 09:18 GMT
I have a Radeon Vega 56 in my desktop PC and also noticed broken shutdown behavior just yesterday. Thank you for figuring out the reason so quickly.
Comment by Frederic Bezies (fredbezies) - Sunday, 19 April 2020, 11:28 GMT
@AK: you're welcome. I just looked at last issues opened with shutdown in their description on bugzilla.kernel.org. Bug #207331 was the right one... So :)

Loading...