Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66273 - [libuv] 1.36.0 breaks [bind] with incompatible changes

Attached to Project: Arch Linux
Opened by Alexander Schnaidt (Namarrgon) - Thursday, 16 April 2020, 10:59 GMT
Last edited by Felix Yan (felixonmars) - Monday, 20 April 2020, 14:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 21
Private No

Details

Description:
'named' crashes on start after the update to libuv 1.36.0:
https://github.com/libuv/libuv/issues/2791
https://gitlab.isc.org/isc-projects/bind9/-/issues/1761
gentoo-user@lists.gentoo.org/msg179985.html"> https://www.mail-archive.com/gentoo-user@lists.gentoo.org/msg179985.html

A hot-fix that reverts the behavior is available until upstream comes up with a proper fix:
https://github.com/libuv/libuv/pull/2792

This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 20 April 2020, 14:52 GMT
Reason for closing:  Upstream
Additional comments about closing:  1.37.0-1
Comment by Jens G (Thah) - Friday, 17 April 2020, 08:49 GMT
I can confirm the crash. Downgrading to libuv 1.35.0-1 fixes it.
Comment by BAD+MAD (mat_weiss) - Friday, 17 April 2020, 11:19 GMT
Same here after changing to LTS Kernel.

uname -r: 5.4.32-1-lts

Downgrading libuv solves it for me too.
Comment by Antoine Pietri (seirl) - Saturday, 18 April 2020, 15:03 GMT
Can also confirm here.

One line fix for people affected:

sudo pacman -U https://archive.archlinux.org/packages/l/libuv/libuv-1.35.0-1-x86_64.pkg.tar.zst
Comment by DJ Lucas (DJ_Lucas) - Sunday, 19 April 2020, 05:46 GMT
Confirmed https://github.com/libuv/libuv/pull/2792 works as expected. It's a reversion, so patch -Rp1.
Comment by Pascal Ernster (hardfalcon) - Sunday, 19 April 2020, 14:35 GMT
https://github.com/libuv/libuv/pull/2799 fixes the issue for me without having to revert prior git commits.
Comment by DJ Lucas (DJ_Lucas) - Sunday, 19 April 2020, 22:56 GMT
1.37.0-1 is in now, fixed.
Comment by BAD+MAD (mat_weiss) - Monday, 20 April 2020, 06:16 GMT
Version "libuv-1.37.0-1" seems to be the solution.

Thanks a lot.

Loading...