Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66258 - [inkscape] update to python 3.x

Attached to Project: Arch Linux
Opened by Michel (xantares) - Tuesday, 14 April 2020, 17:58 GMT
Last edited by freswa (frederik) - Sunday, 24 May 2020, 16:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

this package now depends on python2

seems upstream supports python 3.x

what prevents us to drop the python2 dependencies ?
This task depends upon

Closed by  freswa (frederik)
Sunday, 24 May 2020, 16:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  inkscape 1.0
Comment by Gaetan Bisson (vesath) - Tuesday, 14 April 2020, 19:49 GMT
The problem is mostly that not all extensions are compatible with python3. But feel free to submit a patch to our PKGBUILD so we can discuss if moving to python3 is worth it in terms of what extensions we lose. Cheers.

Loading...