Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66242 - [util-linux] sfdisk: output of `sfdisk -d` is not reusable due to `sector-size`

Attached to Project: Arch Linux
Opened by Jordan (oofnik) - Monday, 13 April 2020, 18:29 GMT
Last edited by Christian Hesse (eworm) - Monday, 13 April 2020, 21:29 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

A bug was fixed upstream in sfdisk on 2020-02-04. The bug prevents sfdisk dumps from being restored properly due to the addition of a new field `sector-size`. The bug was fixed by upstream commit 00e53f1 (now included in stable/2.35). It has been released as 2.35.1-2, but the release is not tagged.

It was requested that this issue be filed as a bug report / backport request and not flagged out-of-date.


Additional info:
* package version: 2.35.1-1
* link to upstream bug report: https://github.com/karelzak/util-linux/issues/949

Steps to reproduce:
$ sfdisk -d image.img > image.sfdisk
$ sfdisk image.img < image.sfdisk

The restore command results in the following error:
>>> line 7: unsupported command
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 13 April 2020, 21:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  util-linux 2.35.1-2

Loading...