Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66183 - [linux] i915 not obeying frequency limits and damaging hardware

Attached to Project: Arch Linux
Opened by Chandradeep Dey (chandradeepdey) - Thursday, 09 April 2020, 09:16 GMT
Last edited by freswa (frederik) - Saturday, 11 April 2020, 14:35 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

https://bugzilla.kernel.org/show_bug.cgi?id=203903
I don't know from when the issue existed on my laptop. I was looking at the bugtracker for i915 related issues and found it.

Affected versions:
I had packages for 5.5.13, 5.6.2, 5.6.3. All of them has this.
linux-lts does not show this behaviour. However, the bug report mentions 5.2 which I never tested.

Device:
Acer Predator G3-572 (the bug report also mentions an acer device so I thought this might be relevant)
7700HQ + 1050 Ti, using PRIME render offload
This task depends upon

Closed by  freswa (frederik)
Saturday, 11 April 2020, 14:35 GMT
Reason for closing:  Not a bug
Additional comments about closing:  https://gitlab.freedesktop.org/drm/intel /-/issues/1500
Comment by loqs (loqs) - Thursday, 09 April 2020, 16:07 GMT
See https://gitlab.freedesktop.org/drm/intel/-/wikis/How-to-file-i915-bugs the i915 module does not use the kernel bugzilla for bug tracking.
Please also retest on drm-tip as requested in the link.
Comment by Chandradeep Dey (chandradeepdey) - Saturday, 11 April 2020, 08:27 GMT
@loqs i could not get the kernel up and running. do they not accept reports made using other kernels at all?
Here are the stuff I used. PKGBUILD is from AUR/linux-drm-tip-git with some modifications. config and sphinx-workaround.patch are from core/linux, no modifications. linux.install is from AUR/linux-drm-tip-git unchanged.
PKGBUILD - https://hastebin.com/erihahafuv.bash
config - https://hastebin.com/uhicibavur.ini
sphinx-workaround.patch - https://hastebin.com/wuxemeyanu.nginx
linux.install - https://hastebin.com/kogucufura.bash
Comment by loqs (loqs) - Saturday, 11 April 2020, 10:24 GMT
Include a note in the bug report that drm-tip is not working for you. Do remember to include dmesg from a boot with drm.debug=0x1e log_buf_len=1M
linux.install is not needed and the PKGBUILD you are using does not call it.

Loading...