Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66173 - [prusa-slicer] missing dependency on cgal

Attached to Project: Community Packages
Opened by rew1red (rew1red) - Wednesday, 08 April 2020, 16:57 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Wednesday, 08 April 2020, 18:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

prusa-slicer 2.2.0-1 will not launch, it appears that a library is missing:

```
prusa-slicer: error while loading shared libraries: libCGAL.so.13: cannot open shared object file: No such file or directory
```

The prusa-slicer changelog reports that, as of version 2.2.0 "The hollowing and hole drilling features rely on OpenVDB and CGAL libraries. Many thanks to the authors of the two libraries."
(https://github.com/prusa3d/PrusaSlicer/releases). I assume based on this information that libCGAL was added as a dependency, and the Arch package must also at libCGAL and OpenVDB as dependencies.

Additional info:
prusa-slicer 2.2.0-1
https://github.com/prusa3d/PrusaSlicer/releases


Steps to reproduce:
1. Install prusa-slicer
2. Launch prusa-slicer with no flags or options.
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Wednesday, 08 April 2020, 18:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  Sorry, I focused a lot on trying to use a system libigl and miniz, and in the end missed that simple thing. Fixed in 2.2.0-2.
Comment by loqs (loqs) - Wednesday, 08 April 2020, 17:09 GMT

Loading...