Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#6617 - snd_hda_intel driver does not work with new kernel.

Attached to Project: Arch Linux
Opened by Kishore Deva (kishd) - Saturday, 17 March 2007, 19:11 GMT
Last edited by Roman Kyrylych (Romashka) - Sunday, 18 March 2007, 07:53 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture not specified
Severity Critical
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Since kernel26-2.6.20-6 the snd_hda_intel driver stopped working. The module loads but the soundcard is not detected. Downgrading to kernel26-2.6.20-4 results in the soundcard being detected and functional again. I cannot get the soundcard detected with any of the newer kernels.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 24 March 2007, 15:35 GMT
Reason for closing:  Fixed
Comment by Georg Grabler (STiAT) - Wednesday, 21 March 2007, 17:06 GMT
I'm using the current kernel26, and snd_hda_intel works properly without any extra configuration (except in modprobe.conf the "options snd-hda-intel model=uniwill-m31", which should not have any effect on the module loading itself).

Comment by Kishore Deva (kishd) - Wednesday, 21 March 2007, 17:57 GMT
Tried almost all the options and still even though the module is loaded my soundcard is not detected. Reverting to the older kernel.
Comment by L. TANGUY (sk) - Wednesday, 21 March 2007, 19:02 GMT
Same here with the current kernel26, on an Asus P5B Deluxe: module loads, but it doesn't seem to find any codec.

Found in dmesg when loading snd-hda-intel module:
hda-intel: no codecs found!
Comment by Tobias Powalowski (tpowa) - Wednesday, 21 March 2007, 19:25 GMT
ok you guys, have entries in /etc/modprobe.conf am i right?
you used alsaconf for sound configuration right?

please remove the alsa entries from /etc/modprobe.conf.
you could also try to manually load your modules in rc.conf that udev does not mess up the module loading.
Comment by L. TANGUY (sk) - Wednesday, 21 March 2007, 20:17 GMT
I have no entries in /etc/modprobe.conf and I never used alsaconf.
The soundcard worked out of the box with prior kernel26 versions.

Meanwhile, alsaconf detects the soundcard correctly, but I still have the same error in the dmesg.

Btw, same behaviour when the module is manually loaded in rc.conf:

:: Restoring ALSA Levels [BUSY]
/usr/sbin/alsactl: load_state:1327: No soundcards found...
Clearing /etc/asound.state didn't help.

It doesn't seem like a specific problem with as a quick browse on lkml doesn't show any bug reports of similar problems.
Comment by Tobias Powalowski (tpowa) - Wednesday, 21 March 2007, 20:22 GMT
does manual loading of modules help?
try to load your needed modules in rc.conf and then recheck, it could be that udev loads the modules in wrong order.

what does hwdetect --show-modules give you?
pacman -S hwdetect
Comment by L. TANGUY (sk) - Wednesday, 21 March 2007, 20:33 GMT
Manual loading doesn't help.

# hwdetect --show-modules
AGP : agpgart intel-agp
PATA : pata_jmicron ata_generic
SCSI : sd_mod
SATA : ahci
USB : usbcore ehci-hcd uhci-hcd
FW : ieee1394 ohci1394
NET : ppp_generic sk98lin skge sky2 slhc
INPUT : evdev ff-memless joydev pcspkr psmouse serio_raw tsdev usbhid
SOUND : snd-mixer-oss snd-pcm-oss snd-page-alloc snd-pcm snd-timer snd snd-hda-codec snd-hda-intel soundcore
VIDEO : nvidia nvidiafb
OTHER : cdrom rtc hid i2c-algo-bit i2c-i801 i2c-core pci_hotplug shpchp

Can you point me to an earlier version of this package (for example kernel26, so I can test if I can reproduce the problem with it ?
Comment by Tobias Powalowski (tpowa) - Wednesday, 21 March 2007, 20:38 GMT
in which order did you load the modules?
Comment by L. TANGUY (sk) - Wednesday, 21 March 2007, 21:00 GMT
I used "modprobe snd_pcm" to load the generic alsa subsystem and then:
insmod snd-hda-codec.ko
insmod snd-hda-intel.ko

snd-hda-codec is always loaded before snd-hda-intel.

Comment by L. TANGUY (sk) - Wednesday, 21 March 2007, 21:18 GMT
I missed this post on the archlinux forums on my first search:
I think the issue discussed here is exactly the same.
I'll try to rebuild the kernel26 package with this patch reverted:
Comment by Tobias Powalowski (tpowa) - Thursday, 22 March 2007, 07:02 GMT
new kernel-2.6.20-3 should fix your issue, please report success.
Comment by Cristian Gimenez (kastor) - Thursday, 22 March 2007, 18:43 GMT
the same issue with kernel26beyond and kernel26ck
Comment by Cristian Gimenez (kastor) - Thursday, 22 March 2007, 19:07 GMT
works fine for me thanks
Comment by Kishore Deva (kishd) - Thursday, 22 March 2007, 19:21 GMT
Thank you very much tpowa. Works like a dream.
Comment by L. TANGUY (sk) - Thursday, 22 March 2007, 19:39 GMT
Argg... doesn't work for me
Comment by L. TANGUY (sk) - Saturday, 24 March 2007, 11:20 GMT
A better patch was committed upstream:

#define AZX_MAX_CODECS 4 corrects the behaviour of ATI-based HDA soundcards.

Meanwhile, mine is an ADI AD1988B that should not be affected. I posted a bug upstream as I can reproduce it with a vanilla kernel:

Comment by Tobias Powalowski (tpowa) - Saturday, 24 March 2007, 11:20 GMT
its in .4 kernel that i'll commit right now