Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66136 - [refind-efi] refind-efi depends on "which" to run efibootmgr to create boot manager entry

Attached to Project: Arch Linux
Opened by r3muxd (r3muxd) - Sunday, 05 April 2020, 20:44 GMT
Last edited by David Runge (dvzrv) - Wednesday, 22 April 2020, 11:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
In AddBootEntry in refind-install, there's a check to find efibootmgr

Efibootmgr=`which efibootmgr 2> /dev/null`

This check fails if "which" is not present, causing rEFInd to fail to install properly by not creating an EFI boot manager entry.
Additional info:
* package version(s): refind-efi 0.11.3-1, latest
* config and/or log files etc. n/a
* link to upstream bug report, if any n/a



Steps to reproduce:
1. Run "refind-install"
2. Get
"ALERT: There were problems running the efibootmgr program! You may need to
rename the $Refind binary to the default name (EFI/boot/bootx64.efi
on x86-64 systems or EFI/boot/bootia32.efi on x86 systems) to have it run!"
3. rEFInd does not create a boot manager entry

Flagged as high because refind-efi is marked "out of date", but is still recommended in Arch Wiki with no note.
This task depends upon

Closed by  David Runge (dvzrv)
Wednesday, 22 April 2020, 11:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  refind 0.12.0-3 has which in depends

Loading...