Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66128 - [go] concurrency bug in version between 1.13.8 and 1.14.2

Attached to Project: Community Packages
Opened by Ruben Kelevra (RubenKelevra) - Sunday, 05 April 2020, 11:08 GMT
Last edited by Morten Linderud (Foxboron) - Wednesday, 13 May 2020, 19:40 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Morten Linderud (Foxboron)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
There's a bug in go, which leads to hungups in certain situations.

The bug in the bugtracker:
https://github.com/golang/go/issues/38119

This package should be downgraded and compiled software should be recompiled with 1.13.8 until 1.14.2 is out.
This task depends upon

Closed by  Morten Linderud (Foxboron)
Wednesday, 13 May 2020, 19:40 GMT
Reason for closing:  No response
Additional comments about closing:  Probably fixed with 1.14.2
Comment by Morten Linderud (Foxboron) - Sunday, 05 April 2020, 12:36 GMT
No, the package isn't getting a downgrade unless someone comes up with a large amount of packages built towards 1.14.1 that actively fails. 1.4.2 is either out soon or we backport the patch they provide.
Comment by Ruben Kelevra (RubenKelevra) - Sunday, 05 April 2020, 14:00 GMT
IPFS and kubernetes are confirmed to be affected and every program which uses a high amount of concurrencies and is build on a system running go 1.14.1.

Downgrading until 1.14.2 comes out sounded for me as the best option since it isn't breaking anything (all software should compile fine with 1.13.8) and is well tested.

I can confirm the bug is fixed when recompiling IPFS with 1.13.8 and it is also confirmed for other software:

https://github.com/golang/go/issues/38023#issuecomment-603604549

Backporting the patch, on the other hand, would require some testing if this will fixes the bug.
Comment by Morten Linderud (Foxboron) - Sunday, 05 April 2020, 14:06 GMT
>Downgrading until 1.14.2 comes out sounded for me as the best option since it isn't breaking anything (all software should compile fine with 1.13.8) and is well tested.

It implies a complete rebuild of current go software. It's not happening.


You are also not reading the complete issue. The linked issue (38119) and the second issue (38023) are not the same bug. 38119 hasn't had any real world examples and as noted is probably for downstream projects to patch, and 38023 is a separate issue.
Comment by Morten Linderud (Foxboron) - Tuesday, 14 April 2020, 07:38 GMT
Please ack or nack if 1.14.2 has fixed this issue or not.

Loading...