FS#66127 - [mupdf] Problems searching in LaTeX pdfs

Attached to Project: Community Packages
Opened by sekret (sekret) - Sunday, 05 April 2020, 10:11 GMT
Last edited by Toolybird (Toolybird) - Monday, 17 April 2023, 07:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I'm having issues searching through my LaTeX documents. I narrowed it down to \usepackage[T1]{fontenc} and \usepackage{lmodern}. With those removed / commented searching works again.

Here's a minimal example: http://ix.io/2gIn/TeX

Building the pdf with pdflatex file.tex I can search through the pdf file. If I uncomment and include either the fontenc or the lmodern or both, searching doesn't work anymore.

It's not a LaTeX / TexLive issue, because I tried searching through older documents, which I'm sure I was able to search in. Doesn't work anymore. And with e.g. Evince there's no problem at all.

Additional info:
* package version(s)
$ pacman -Qi mupdf | grep Version
Version : 1.16.1-3

* config and/or log files etc.
none of the two packages included: http://ix.io/2gIp
fontenc included: http://ix.io/2gIq
lmodern included: http://ix.io/2gIr
both packages included: http://ix.io/2gIs

* link to upstream bug report, if any
none to be found

Steps to reproduce:
Save the minimal example with e.g. filename test.tex, then run "pdflatex test.tex", then open the resulting pdf file in mupdf and search for e.g. "Lorem". It will be found. Now include one of the packages or both by uncommenting the corresponding commented lines, run "pdflatex test.tex" again, open the pdf file in mupdf and search for e.g. "Lorem". It will NOT be found. In fact nothing will be found.
This task depends upon

Closed by  Toolybird (Toolybird)
Monday, 17 April 2023, 07:33 GMT
Reason for closing:  None
Additional comments about closing:  Old and stale. If still an issue, please report upstream.
Comment by sekret (sekret) - Monday, 06 April 2020, 15:41 GMT
I just had an idea. I checked, if it also occurs with zathura and the mupdf backend. Yes, same result. With the poppler backend I can find the words I'm searching for.
Comment by Daniel Lublin (quite) - Monday, 19 April 2021, 13:33 GMT
Can't reproduce this using mupdf-gl 1.18.0-2 and freetype2 2.10.4-1