Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66126 - Some zenity dialogs do not work anymore.

Attached to Project: Arch Linux
Opened by Antonio Corbi bellot (acorbi) - Sunday, 05 April 2020, 09:18 GMT
Last edited by freswa (frederik) - Sunday, 05 April 2020, 12:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Zenity does not show some of it's dialogs since a few days (maybe a gtk update related bug?).
For example, this worked before:

zenity --question --text "hello"

Now I only get in the terminal:

(zenity:26750): Gtk-WARNING **: 11:04:39.018: gtk_widget_size_allocate(): attempt to allocate widget with width -3 and height -3

(zenity:26750): Gtk-WARNING **: 11:04:39.018: gtk_widget_size_allocate(): attempt to allocate widget with width -9 and height 48

And no dialog on screen.

Additional info:
* package version(s)

zenity version: 3.32.0+17+gfb0938f-1
gtk3 version: 1:3.24.17-2

Steps to reproduce:

The one above, some more working/non-working examples:

Not working: zenity --calendar
Working: zenity --file-selection

This task depends upon

Closed by  freswa (frederik)
Sunday, 05 April 2020, 12:22 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#66106 

Loading...