Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66119 - [gtk3] Closing and reopening nautilus gradually increases its window size

Attached to Project: Arch Linux
Opened by Amal Karunarathna (r3b311i0n) - Sunday, 05 April 2020, 00:35 GMT
Last edited by Jan de Groot (JGC) - Monday, 20 April 2020, 10:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After upgrading gtk3 to 1:3.24.17-2 closing nautilus and reopening it creates a window which is slightly larger than the previously closed window. Doing so again, creates an even larger window. Downgrading to gtk3 1:3.24.16-1 fixes the issue.


Package versions:

* gtk3 1:3.24.17-2
* nautilus 3.36.1.1-1

Steps to reproduce:

* Upgrade gtk3 to 1:3.24.17-2
* Open nautilus
* Close nautilus with a non-maximised window
* Reopen nautilus
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 20 April 2020, 10:28 GMT
Reason for closing:  Fixed
Comment by Jonas Witschel (diabonas) - Sunday, 05 April 2020, 11:46 GMT
Upstream bug report: https://gitlab.gnome.org/GNOME/gtk/-/issues/2576. Also see  FS#66106  for related GTK 3.24.17 breakage.
Comment by Amal Karunarathna (r3b311i0n) - Tuesday, 07 April 2020, 09:05 GMT
This seems to be fixed with gtk3 1:3.24.17+15+gdc79e07228-1.
Comment by Carlos (memeplex) - Wednesday, 08 April 2020, 00:28 GMT
I can confirm this is working fine after last update. Also upstream issue has been fixed and closed this morning.

Loading...