Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66103 - [systemd] systemd-245.4-2 breaks systemd-homed logins

Attached to Project: Arch Linux
Opened by Doğukan Korkmaztürk (dogukan) - Saturday, 04 April 2020, 00:04 GMT
Last edited by Christian Hesse (eworm) - Friday, 17 April 2020, 20:30 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

On my system, I am unable to login to my systemd-homed user after updating systemd and systemd-libs packets to 245.4-2 from 245.4-1. I tried to login from both gdm and tty. Downgrading these two packets to 245.4-1 solves the problem. I use the following configuration.

* /dev/nvme1n1p1 -> /, f2fs
* /dev/nvme1n1p2 -> /home, f2fs with encryption enabled
* Created the user I mentioned above using this command: homectl create <username> --storage=fscrypt --shell=/bin/zsh (When I created this user, I was using a systemd version less than 245.4, 245.2 maybe?)
* Applied the PAM configuration from here: https://wiki.archlinux.org/index.php/Systemd-homed#Enabling_PAM_modules
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 17 April 2020, 20:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  intended
Comment by loqs (loqs) - Saturday, 04 April 2020, 00:17 GMT
What is the status of the service? systemctl status systemd-homed.service
Comment by Doğukan Korkmaztürk (dogukan) - Saturday, 04 April 2020, 02:01 GMT
Oh thanks for pointing this out. It seems like the service was not running and starting the service solved the problem. It seems like there is a change in behavior of this packet. I think this change should have been announced clearly.
Comment by Christian Hesse (eworm) - Friday, 17 April 2020, 20:30 GMT
Guess I should have printed a note... Will do next time.
Anyway - it's too late now.

Loading...