Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66097 - [virt-manager] libxml2 missing dependency

Attached to Project: Community Packages
Opened by a (a) - Friday, 03 April 2020, 15:17 GMT
Last edited by Jonas Witschel (diabonas) - Friday, 03 April 2020, 21:45 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I didn't have any missing dependencies (for what `pactree says`) but I got this missing module at execution, so it should be added as a dependency


Additional info:
* package version(s): 2.2.1-2
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce: Install `virt-manager` on a fresh Arch and try to execute it
This task depends upon

Closed by  Jonas Witschel (diabonas)
Friday, 03 April 2020, 21:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Corrupt libxml2 package installation
Comment by Jonas Witschel (diabonas) - Friday, 03 April 2020, 16:06 GMT
I fail to see how libxml2 could possibly be missing since it is pulled in by multiple indirect dependencies, the shortest path being virt-manager → gtksourceview4 → libxml2.
Comment by a (a) - Friday, 03 April 2020, 17:39 GMT
Sorry it comes from me. `libxml2` is installed by dependencies but at execution of `virt-manager` it still says that theres no `libxml2` module and it don't start
Comment by Jonas Witschel (diabonas) - Friday, 03 April 2020, 18:03 GMT
I cannot reproduce this on my system, we are going to need more detailed information from you:

- How are you trying to launch virt-manager (terminal or desktop entry)?
- What is the *exact* error message you are getting, when does it occur and where (terminal or graphical popup)?
- Try starting virt-manager from the terminal, are there any additional messages?
- What is the version of libxml2 that is installed on your system?
Comment by a (a) - Friday, 03 April 2020, 20:38 GMT
I execute it in CLI

The error message is (I guess) a very classical message that you can obtain if you simply uninstall `libxml2` (but for me it's special because I got it while having `libxml2` installed):
```python
Traceback (most recent call last):
File "/usr/share/virt-manager/virt-manager", line 19, in <module>
from virtinst import BuildConfig
File "/usr/share/virt-manager/virtinst/__init__.py", line 49, in <module>
from virtinst.domain import * # pylint: disable=wildcard-import
File "/usr/share/virt-manager/virtinst/domain/__init__.py", line 5, in <module>
from .blkiotune import DomainBlkiotune
File "/usr/share/virt-manager/virtinst/domain/blkiotune.py", line 8, in <module>
from ..xmlbuilder import XMLBuilder, XMLChildProperty, XMLProperty
File "/usr/share/virt-manager/virtinst/xmlbuilder.py", line 16, in <module>
from .xmlapi import XMLAPI
File "/usr/share/virt-manager/virtinst/xmlapi.py", line 7, in <module>
import libxml2
ModuleNotFoundError: No module named 'libxml2'
```
And it occurs in the CLI too, nothing graphical pops up at all

What I did was pretty simple:
```
:: Synchronizing package databases...
core is up to date
extra is up to date
community 4.9 MiB 46.0 MiB/s 00:00 [##############################################################################] 100%
multilib is up to date
warning: libxml2-2.9.10-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) libxml2-2.9.10-1

Total Installed Size: 9.19 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [##############################################################################] 100%
(1/1) checking package integrity [##############################################################################] 100%
(1/1) loading package files [##############################################################################] 100%
(1/1) checking for file conflicts [##############################################################################] 100%
(1/1) checking available disk space [##############################################################################] 100%
warning: could not get file information for usr/lib/python3.8/site-packages/drv_libxml2.py
warning: could not get file information for usr/lib/python3.8/site-packages/libxml2.py
warning: could not get file information for usr/lib/python3.8/site-packages/libxml2mod.so
:: Processing package changes...
(1/1) reinstalling libxml2 [##############################################################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
:: Searching databases for updates...
there is nothing to do
```
It was just to reinstall it, and just after this, it worked. I don't know whats the real matter but it wasn't seems to be "configured" in my system (all worked like a charm at the beginning)
My guessing is that Python somehow completly messed up in my system, so I have to reinstall manually all the python related packaged because Python didn't recognise any of them at all. Everywhere some more `ModuleNotFoundError: No module named`. And I think I will continue to met some more until I reinstall all the packages of my system or find what mess up with Python modules (see here: https://unix.stackexchange.com/questions/577369/plenty-of-missing-python-package/577725#577725)
Comment by Jonas Witschel (diabonas) - Friday, 03 April 2020, 21:45 GMT
That sounds like you somehow managed to to delete the Python modules directory /usr/lib/python3.8/site-packages/; try running "sudo pacman -Qkq" to see which packages report having missing files on your system, these need to be reinstalled.

Loading...