Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66087 - [mesa] heavy glitches on amd ryzen 5

Attached to Project: Arch Linux
Opened by eefano (eefano) - Thursday, 02 April 2020, 20:15 GMT
Last edited by freswa (frederik) - Friday, 15 May 2020, 19:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

All the untextured uniform-colored surfaces are filled with random data from gpu memory,
the pattern changes erratically.
Textured surfaces are fine. You can see in the steam and glxgears screenshots attached.

Tried with current kernel and lts kernel, no difference.
The bug appeared on the latest mesa update i think.
All the details are in the attachments.

On windows the GPU works fine, so i'm excluding hardware faults.

Processor Type: AMD Ryzen 5 2400G with Radeon Vega Graphics
Kernel Release: 5.4.28-2-lts
Mesa Release: 20.0.3-1


This task depends upon

Closed by  freswa (frederik)
Friday, 15 May 2020, 19:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with package version 20.0.7-2
Comment by freswa (frederik) - Thursday, 02 April 2020, 23:24 GMT
Please try downgrading mesa.
Comment by eefano (eefano) - Friday, 03 April 2020, 18:14 GMT
Tested some old versions, this is the latest good one:

mesa-19.3.4-2-x86_64.pkg.tar.zst 14-Feb-2020 22:28 12M


These versions (the entire 20.x branch) are broken:

mesa-20.0.0-1-x86_64.pkg.tar.zst 20-Feb-2020 13:27 12M
mesa-20.0.0-2-x86_64.pkg.tar.zst 22-Feb-2020 16:36 12M
mesa-20.0.1-1-x86_64.pkg.tar.zst 06-Mar-2020 15:21 13M
mesa-20.0.2-1-x86_64.pkg.tar.zst 18-Mar-2020 23:00 14M
mesa-20.0.3-1-x86_64.pkg.tar.zst 02-Apr-2020 07:28 14M
mesa-20.0.4-1-x86_64.pkg.tar.zst 03-Apr-2020 11:57 14M

maybe it should be addressed upstream.
Comment by Gabor Juhasz (jaysicks) - Saturday, 11 April 2020, 14:08 GMT
I may have the same (or related) issue, although the symptoms on my system are slightly different.
I have yellow squares on my wallpaper and some characters are rendered as blurry squares.

If I change the wallpaper (even if I just set the same as before) the glitches on the wallpaper go away until some time - the next restart, or display setup change.

Not sure if relevant, but my two monitors are in an arrangement that the left monitor is lifted slightly higher than the right one.

My video card is NVIDIA GeForce 940M.

The issue first appeared when I upgraded from from 19.3.5-1 (working) to 20.0.4-1 (glitchy).
But also confirmed that 20.0.0-1 shows the same issue.

I tried running glxgears:
19.3.5-1: working fine
20.0.4-1: crashes with segmentation fault

Let me know if I should open a separate ticket or need more info.

Thanks.
Comment by eefano (eefano) - Tuesday, 21 April 2020, 17:50 GMT
Just great, now today Steam crashes at startup if I use Mesa branch 19.x, so I cannot keep those packages downgraded anymore... any news on that?
Comment by AK (Andreaskem) - Tuesday, 21 April 2020, 19:56 GMT
You could try booting with the option iommu=pt on your kernel command line. Some AMD graphics corruption could be fixed by adding it in the past:
https://gitlab.freedesktop.org/drm/amd/issues/842#note_314921
Comment by Joy Narical (narical) - Wednesday, 22 April 2020, 19:00 GMT
Same here.
proc: AMD® Ryzen 3 3200u with radeon vega mobile gfx × 4
Heavy glitches since the beginning of mesa 2.x branch up to mesa-git from mesa-git user repository (1:20.1.0_devel.122623.4daa3917a38-1 currently)
here's how that looks:
https://i.imgur.com/zflIAVP.png - game "Fort Triumph" in Steam
https://i.imgur.com/GvpSrQN.png - Prusa Slicer software.
In second screenshot one can see glitches in tooltips and toolpanes (both left and upper).
Comment by Gabor Juhasz (jaysicks) - Thursday, 23 April 2020, 10:53 GMT
This seems to be fixed for me in 20.0.4-2
(Unfortunately I can't try with 20.0.4-1 anymore, because gnome crashes if I downgrade, probably because other packages have been updated as well, such as lib32-mesa)
Comment by cahiraep (cahiraep) - Friday, 24 April 2020, 14:20 GMT
Has anyone tried if the new Upgrade 20.0.5-1 fixes this?
Comment by eefano (eefano) - Friday, 24 April 2020, 19:15 GMT
Tried mesa 20.0.5-1 today, but it does not resolve.
Comment by Ricardo García (ricardog08) - Wednesday, 06 May 2020, 00:16 GMT
i have same the problem with a ryzen 5 2400g :'c
Comment by eefano (eefano) - Wednesday, 06 May 2020, 15:26 GMT
Don't worry! I have helped the MESA dev team and found the bug for them.
They have created a merge request today and I hope they will release the fix soon.

Issue:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/2814

Merge request:
https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4918

Comment by cahiraep (cahiraep) - Wednesday, 06 May 2020, 18:38 GMT
MY HERO :D
Comment by eefano (eefano) - Friday, 15 May 2020, 12:32 GMT
Mesa released version 20.0.7 upstream yesterday, it contains the fix for this issue. The actual arch package is marked out of date. Hope it will be updated in the next few days.
Comment by cahiraep (cahiraep) - Friday, 15 May 2020, 17:15 GMT
mesa-20.0.7 is now available
Comment by eefano (eefano) - Friday, 15 May 2020, 18:52 GMT
BETTER NOT UPDATE BY NOW, the 20.0.7 SEGFAULTS on every OPENGL application! That's a major screwup!
Comment by eefano (eefano) - Friday, 15 May 2020, 19:01 GMT
thankfully arch quickly updated to 20.0.7-2 that fixed the segfault and the original issue.

Loading...