Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66078 - [qtcreator] clangbackend broken in 4.11.2-1.

Attached to Project: Arch Linux
Opened by Knut Tidemann (Avenger) - Thursday, 02 April 2020, 08:07 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 02 April 2020, 21:57 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The clangbackend binary stopped working in the Qt Creator 4.11.2-1 update from testing.

When I try to run it I get:
Inconsistency detected by ld.so: rtld.c: 1492: dl_main: Assertion `GL(dl_rtld_map).l_libname' failed!

Steps to Reproduce:
I did a -Syu on April 1st which updated the qtcreator package to 4.11.2-1, clangbackend was then broken both when launched by qt creator and when trying to run it on its own.

I tried to rebuild the qtcreator package, but it did not help.

Downgrading to qtcreator 4.11.1-1 fixes the issue.


This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 02 April 2020, 21:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  qtcreator 4.11.2-2
Comment by Tobias Hunger (hunger) - Thursday, 02 April 2020, 10:25 GMT
Qt Creator 4.11 (as well as 4.12) were never tested with anything but clang 8 and needs patches on top of normal clang. I think those extra patches are mostly relevant for windows, so you might get by without them;-)

I would recommend to disable clang in the package for the time being.

Clang 10 support _might_ happen in the 4.13 release and may or may not need extra patches.
Comment by Antonio Rojas (arojas) - Thursday, 02 April 2020, 10:38 GMT
@hunger as the OP said, 4.11.1 worked fine with the exact same clang version, so it's not a problem with clang itself.

4.11.1 built against current packages also shows the issue, so it's also not caused by a change in qtcreator.

So this must be caused by some library update between 6/2 and 31/3. Currently trying to identify which one it is, help is appreciated.
Comment by Tobias Hunger (hunger) - Thursday, 02 April 2020, 13:36 GMT
I never said this does not link:-) But the clang-based functionality in creator is known to work reliably with a patched clang 8 *only*. Everything else is unsupported.

I hope that we will finally catch up with clang again in Creator 4.13!
Comment by Antonio Rojas (arojas) - Thursday, 02 April 2020, 14:04 GMT
OK turns out it's GCC - with gcc 9.2.0 it works, with gcc 9.2.1+20200130 it's broken

Loading...