Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#66061 - [linux] latest kernel wifi issues with ath9k

Attached to Project: Arch Linux
Opened by kuesji koesnu (kuesji) - Wednesday, 01 April 2020, 11:10 GMT
Last edited by David Runge (dvzrv) - Thursday, 23 April 2020, 15:34 GMT
Task Type Bug Report
Category Packages: Core
Status Assigned
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No


wifi not working in latest kernel(5.5.13-arch2).
i stay at downgraded kernel(5.5.10.arch1-1) until fixed but i think i should inform you.

adapter : Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
driver : ath9k
client: network manager

Steps to reproduce:
- just try to connect wifi and watch logs via journalctl -u NetworkManager.
you will see some timeout and disconnect logs.
This task depends upon

Comment by freswa (frederik) - Wednesday, 01 April 2020, 12:17 GMT
Please provide the logs from NetworkManager. Does it work with wpa_supplicant?
Comment by Alex (achrono) - Thursday, 02 April 2020, 00:09 GMT

I have the same issue, although I am using the broadcom-wl drivers ( I hope it is alright for me to comment here. If i need to open a separate ticket please let me know. It is my first time posting.

My network interface is: Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)
Laptop is a MacBookPro11,3

Attached are my NetworkManager logs. I upgraded at 7:56am and restarted. It seems that I lost the wl kernel module as NetworkManager did not detect my wireless interface wlp3s0 after the reboot. It was working fine prior to the reboot. Running lsmod | grep wl produced no output.

I tried inserting the wl kernel module using insmod and modprobe without success.

Mar 31 17:52:24 arch sudo[9513]: alex : TTY=pts/1 ; PWD=/home/alex ; USER=root ; COMMAND=/usr/bin/modprobe wl --verbose
Mar 31 17:52:24 arch kernel: wl: version magic '5.5.13-arch1-1 SMP preempt mod_unload ' should be '5.5.13-arch2-1 SMP preempt mod_unload '

I also tried removing broadcom-wl and installing again without success.

I hope this is helpful. If I can provide any more information please let me know.

Thank you,

Comment by Doug Newgard (Scimmia) - Thursday, 02 April 2020, 13:23 GMT
Alex, that's an external module problem, totally different from what the OP has. You have an unsupported partial update, so it's not a bug at all.
Comment by kuesji koesnu (kuesji) - Monday, 06 April 2020, 11:11 GMT
sorry for my late answer. everything is normal in the logs, just some timeout warnings. networkmanager didn't find/give any error.
i thought problem is driver for this reason.