Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66053 - [libressl] Create ldconfig configuration file

Attached to Project: Community Packages
Opened by Jens Carl (Jenne) - Tuesday, 31 March 2020, 23:08 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Tuesday, 07 April 2020, 18:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Installation of libressl 3.0.2-1 package doesn't create ldconfig configuration file.

Additional info:
* libressl 3.0.2-1
* starting the program results in an error:
libressl-test: error while loading shared libraries: libcrypto.so.45: cannot open shared object file: No such file or directory
* ldd output: ldd ./libress-test (shows not found: marked with ->)
linux-vdso.so.1 (0x00007ffc895f2000)
libboost_program_options.so.1.72.0 => /usr/lib/libboost_program_options.so.1.72.0 (0x00007fac660bd000)
-> libcrypto.so.45 => not found
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fac65ed4000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fac65eba000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007fac65cf4000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007fac65ce9000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007fac65ba1000)
/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007fac661a5000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fac65b7f000)

Steps to reproduce:

- compile a C/C++ program with flags provided by pkgconf
compiler flags: -I/usr/include/libressl
linker flags: -L/usr/lib/libressl -lssl -lcrypto
- run program

This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Tuesday, 07 April 2020, 18:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  We cannot add a ldconfig for libressl, because then it would take precedence over openssl. So you do have to specify a rpath during linking, `-Wl,-rpath=/usr/lib/libressl`.
Comment by loqs (loqs) - Tuesday, 31 March 2020, 23:27 GMT
Please try adding -rpath=/usr/lib/libressl to the linker flags.

Loading...