Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65984 - Non translated sentence in second and more level dialog window in Gimp

Attached to Project: Arch Linux
Opened by R. Ouellette (rouelle) - Thursday, 26 March 2020, 02:29 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 26 March 2020, 14:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

All second level dialog box and subsequent are not translated. Verified with french (and french_CA) locale. I even recopy /usr/share/locale/fr/LC_MESSAGES/gimp20-libgimp.mo in /usr/share/locale/fr_CA/LC_MESSAGES/gimp20-libgimp.mo but the behavior stays the same after restarting gimp. I reported first this bug to Gimp developers but it was not reproducible. See https://gitlab.gnome.org/GNOME/gimp/-/issues/4871#note_750032

Additional info:
* version: gimp 2.10.18-4 (extra)
* report and answer from gimp developers at https://gitlab.gnome.org/GNOME/gimp/-/issues/4871#note_750032

Steps to reproduce:
Any second level and subsequent dialog window appear in english despite french locale.
This behavior was present at least since version 2.10.14.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 26 March 2020, 14:23 GMT
Reason for closing:  Not a bug
Comment by Jonas Witschel (diabonas) - Thursday, 26 March 2020, 09:21 GMT
What steps did you take to change the language? I can reproduce this issue when setting the language to French in the GIMP options (Edit → Preferences → Interface). In that case, the debug output on the terminal seems to imply that GIMP fails to set the language correctly everywhere: "(file-jpeg:142783): Gtk-WARNING **: 10:03:54.955: Locale not supported by C library. Using the fallback 'C' locale."

On the other hand, setting the system language to French (uncommenting "fr_CA.UTF-8 UTF-8" in /etc/locale.gen, running "sudo locale-gen", starting GIMP as "LANG=fr_CA.UTF-8 gimp") works as expected and translates the export dialogue as well, so I suggest doing that instead of using the builtin language selection.

All things considered, this doesn't appear to be an issue with the Arch Linux packaging since the translations are definitely there and can be activated by setting the system language to French. Please continue your conversation in the upstream bug tracker to figure out why setting the language in the GIMP settings doesn't work as expected.
Comment by R. Ouellette (rouelle) - Thursday, 26 March 2020, 13:38 GMT
I tried to launch GIMP as "LANG=fr_CA.UTF-8 gimp" but had the same behavior... So I change manually the language from french to system language in the builtin language selection and that did the trick!

So, strange, but setting the language this way is ok with me and it's the default behavior of GIMP.

Loading...