Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65983 - [libappindicator-gtk3] Build breaks when package 'mono' is installed as well

Attached to Project: Community Packages
Opened by Max Rumpf (Maxr1998) - Wednesday, 25 March 2020, 23:48 GMT
Last edited by freswa (frederik) - Thursday, 26 March 2020, 00:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When building libappindicator[-gtk3] with makepkg, the build fails if the 'mono' package is also installed on the system. I've confirmed this in a freshly set up Docker instance of Arch as well as on my own installation. Build passes without any issues when mono isn't installed but fails if it is.

Relevant make output on error:

make[4]: Entering directory '/home/test/libappindicator/src/libappindicator-12.10.0/bindings/mono'
sed '/signals\[X_NEW_LABEL\] /,+6d' ../../src/app-indicator.c > app-indicator.c
no app-indicator.sources.xml
make[4]: no: No such file or directory
make[4]: *** [Makefile:811: libappindicator-api.raw] Error 127
make[4]: Leaving directory '/home/test/libappindicator/src/libappindicator-12.10.0/bindings/mono'
make[3]: *** [Makefile:532: all-recursive] Error 1


The relevant buildscript portion seems to be

$(GAPI_PARSER) app-indicator.sources.xml

in line 811 of libappindicator-12.10.0/bindings/mono/Makefile.in, where a missing GAPI_PARSER (set to "no") seems to cause execution of a non-existent command, breaking the build.


Additional info:
* Tested on libappindicator-12.10.0-14 and mono 6.4.0.198-1

Steps to reproduce:
* Export the latest libappindicator with asp on a system with the 'mono' package installed
* Build with makepkg
This task depends upon

Closed by  freswa (frederik)
Thursday, 26 March 2020, 00:36 GMT
Reason for closing:  Not a bug
Additional comments about closing:  All packages are supposed to be built within a clean root.

Loading...