Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65979 - [qgis] When Grass GIS installed, Grass is not availaible as a plugin

Attached to Project: Community Packages
Opened by Sylvain POULAIN (kikislater) - Wednesday, 25 March 2020, 19:54 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 25 March 2020, 22:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Grass GIS is usually available in QGIS through two components : processing algorithms and as an extension. Processing allow to run some Grass GIS algorithm whereas Grass GIS extension is a complete integration of Grass GIS in Qgis. Nowaday Qgis is a toolbox of multiple GIS tools such as Gdal ... Previously in Archlinux, we were able to install Qgis and lately install Grass GIS. Then launching Qgis and running Grass GIS as a QGIS extension was possible. It's not more feasible and provide a counter productive use of QGIS under Archlinux.

grass folder in /usr/share/qgis/grass is not available in list files


Additional info:
* package version(s) : QGIS 3.12.0-1
* config and/or log files etc.
* link to upstream bug report, if any : not related, was working before

Steps to reproduce:

1) Install QGIS,
2) Install GRASS GIS from AUR (only available in AUR unforunately even if major GIS package)
3) Open QGIS and look for GRASS GIS extension from Menu Extension => Install and Manage Extension
=> no Grass GIS extension available.
4) Rebuild package QGIS with GRASS GIS installed and you could see GRASS extension present in QGIS
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 25 March 2020, 22:47 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Totally expected. You have to build QGIS against GRASS yourself.

Loading...