Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65914 - [archlinux-appstream-data] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by Oleg (vs220) - Saturday, 21 March 2020, 10:13 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 21 March 2020, 12:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


Additional info:
package version(s): archlinux-appstream-data 20200315-1
Steps to reproduce:run /usr/bin/pamac-manager

** (process:18891): WARNING **: 11:36:14.420: database.vala:106: Failed to parse /usr/share/app-info/xmls/community.xml.gz file: Error on line 51025 char 10: <p> already set '


This is an error in the file /usr/share/app-info/xmls/community.xml.gz

community.xml :

line 51025:
download files from you, or upload files to you. It does <em> not </em> require setting up a separate server

Please delete <em> </em>
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 21 March 2020, 12:50 GMT
Reason for closing:  Not a bug
Comment by Jonas Witschel (diabonas) - Saturday, 21 March 2020, 11:07 GMT
This is not a bug in archlinux-appstream-data, <em> tags are allowed within paragraphs in the description according to the specification: https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html#tag-description

This appears to be a bug in Pamac, which is not supported by Arch Linux, please report the issue to the Pamac bug tracker instead.
Comment by Oleg (vs220) - Saturday, 21 March 2020, 11:22 GMT
Why is the <em> tag on this line
line 51025:


and
line 50571
<p>Kjo hedhje në qarkullim zhvillim ndreq disa të meta, gabime shkrimi, dhe hollësi historike të pranishme në dokumentim. Tashmë përpunohen etiketa në kartela të dërguara përmes HTTP/S. Mekanizmi <em>clutter video</em> është çaktivizuar për GTK+ 3.22 dhe versione më të rinj, për shkak ndryshime thelbësore të API-t.</p>
Comment by Jonas Witschel (diabonas) - Saturday, 21 March 2020, 11:34 GMT
It emphasises the word "not", applications conforming to the standard would render it e.g. in italics. The AppStream metadata is directly taken from the upstream OnionShare project: https://github.com/micahflee/onionshare/blob/develop/install/org.onionshare.OnionShare.appdata.xml

Again, it is a problem with Pamac if it cannot handle this, the entry is fully conforming with the AppStream specification.
Comment by Oleg (vs220) - Saturday, 21 March 2020, 11:38 GMT
Thanks for the clarification
Comment by Oleg (vs220) - Saturday, 21 March 2020, 12:27 GMT
These seem to be issues in appstream-glib
https://github.com/hughsie/appstream-glib/issues/350

Loading...