Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65895 - [texlive-fontsextra] beamer class doesn't compile due to bug in sansmathaccent.sty

Attached to Project: Arch Linux
Opened by Bennett Piater (ClawOfLight) - Thursday, 19 March 2020, 10:52 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Thursday, 30 April 2020, 20:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Documents using the beamer class do not compile correctly due to a bug in sansmathaccent, which is caused by a bug in filehook.

The bug is fixed in CTAN.
I suggest patching the package to include the following files
http://mirrors.ctan.org/fonts/sansmathaccent/{sansmathaccent.sty,ot1mathkerncmss.fd}
in
/usr/share/texmf-dist/tex/latex/sansmathaccent/

Additional info:
* upstream bug in beamer class: https://github.com/josephwright/beamer/issues/572

Steps to reproduce:
* create a minimal beamer document
* compile
* output:
LaTeX Warning: Command \InputIfFileExists has changed.
Check if current package is valid.


LaTeX Warning: Command \InputIfFileExists has changed.
Check if current package is valid.

) (/usr/local/texlive/2019/texmf-dist/tex/latex/filehook/filehook-scrlfile.sty

/usr/local/texlive/2019/texmf-dist/tex/latex/filehook/filehook-scrlfile.sty:111: Package filehook Error: Detected 'scrlfile' package with unknown definition of \InputIfFileExists.
Use the 'force' option of 'filehook' to overwrite it..
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Thursday, 30 April 2020, 20:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  texlive-fontsextra 2020.54583-1
Comment by Rémy Oudompheng (remyoudompheng) - Thursday, 30 April 2020, 20:10 GMT
This is already fixed in texlixe-fontsextra 2020 package available in [testing]

Loading...