Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65803 - [gnome-shell] empty tooltip-like windows with on-screen keyboard

Attached to Project: Arch Linux
Opened by Gerhard Bogner (slashME) - Thursday, 12 March 2020, 10:31 GMT
Last edited by freswa (frederik) - Thursday, 20 August 2020, 23:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To freswa (frederik)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Since the update to gnome 3.36 I have to enable the on-screen keyboard to input the special characters into gdm's and the lock screen's password fields.

Because of this I noticed that in most applications this keyboard leaves behind an empty transparent window (with a shadow) below the text field. It doesn't update its position when the parent is moved, and doesn't redraw the content until the next time the on-screen keyboard is opened. It also doesn't appear on screenshots, so I attached a photo of an example instead.

I don't know if this bug is new in 3.36, since I didn't have to use this feature since gnome 3.28. I'm running gnome-shell on X11 with the binary Nvidia drivers.

To reproduce enable the on-screen keyboard in the universal access settings, click into any text field and move the parent window (downwards). Something similar happens when trying to rename a file in nautilus.
This task depends upon

Closed by  freswa (frederik)
Thursday, 20 August 2020, 23:27 GMT
Reason for closing:  Upstream
Additional comments about closing:  https://gitlab.gnome.org/GNOME/gnome-she ll/-/issues/2376
Comment by Gerhard Bogner (slashME) - Thursday, 12 March 2020, 13:07 GMT Comment by freswa (frederik) - Thursday, 12 March 2020, 14:14 GMT
Could you please try to downgrade gnome-shell and reproduce the issue? Thank you.
Comment by Gerhard Bogner (slashME) - Thursday, 12 March 2020, 16:24 GMT
downgrading gnome-shell on its own causes it to show a white error screen with a message telling me to restart.
Comment by Gerhard Bogner (slashME) - Thursday, 12 March 2020, 18:14 GMT
gnome-shell on wayland using the intel integrated gpu doesn't seem to be effected.

Loading...