Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65782 - [mate-terminal] URL highlighting broken since vte 0.60

Attached to Project: Community Packages
Opened by Jaume Delclòs Coll (cosarara) - Wednesday, 11 March 2020, 10:49 GMT
Last edited by freswa (frederik) - Friday, 21 August 2020, 23:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Brad Fanella (cesura)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
https://bugs.archlinux.org/task/65772
The URL highlighting feature of mate-terminal breaks after updating vte3 from 0.58.3-1 to 0.60.0-1.
VTE 0.60 removed the implementation for vte_terminal_match_add_gregex, which has been deprecated since VTE 0.46.
https://developer.gnome.org/vte/unstable/VteTerminal.html#vte-terminal-match-add-gregex

Additional info:
* vte 0.60.0-1
* mate-terminal 1.24.0-1 (latest) or 1.22.1-1 (previous).
This issue also affects lxterminal, tilda and terminator.

Steps to reproduce:
* Run mate-terminal
* Go to Edit -> Profile Preferences and ensure the option "Highlight URLs under mouse pointer" is enabled
* type https://bugs.archlinux.org and see that it is not highlighted when hovered with the mouse pointer
This task depends upon

Closed by  freswa (frederik)
Friday, 21 August 2020, 23:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  mate-terminal 1.24.1
Comment by Balló György (City-busz) - Wednesday, 11 March 2020, 11:17 GMT
Please report this problem to upstream:
https://github.com/mate-desktop/mate-terminal/issues
Comment by Jonas Witschel (diabonas) - Wednesday, 11 March 2020, 12:07 GMT
Searching the terminal (menu Search -> Find... / Shift+Ctrl+F) is affected as well.
Comment by Alejandro Perez (alejandro.perez) - Wednesday, 11 March 2020, 12:11 GMT
Also affected here with the Search functionality.
Comment by Jaume Delclòs Coll (cosarara) - Wednesday, 11 March 2020, 14:51 GMT Comment by Jaume Delclòs Coll (cosarara) - Friday, 01 May 2020, 19:23 GMT Comment by Chris Lea (chrislea) - Tuesday, 05 May 2020, 05:18 GMT
The attached PKGBUILD will result in a build that applies the referenced patch and builds cleanly, resulting in a mate-terminal that highlights URLs correctly.
Comment by Chris Lea (chrislea) - Tuesday, 05 May 2020, 05:30 GMT
Sorry, I should have bumped pkgrel to 2. Here's a new PKGBUILD with that change (sorry, I'm pretty new to Arch).
Comment by Jaume Delclòs Coll (cosarara) - Thursday, 07 May 2020, 18:46 GMT
I have tried the PKGBUILD and I can confirm that it works. Thank you, Chris! I hope it can reach the arch repo soon.
Comment by Chris Lea (chrislea) - Sunday, 10 May 2020, 05:19 GMT
Please note also that the upstream maintainer has said in the bug report on GitHub that they won't be making a point release to include this fix because "it's just one commit". He also notes that other distros (Debian, Fedora, etc), have released versions with this patch included without bumping the version.

I'm not a developer on the project so I'm not going to opine about whether or not I think a point release is warranted. However, the broken functionality is something a lot of people rely on. If upstream isn't going to make a point release, then unless Arch ships a release with this patch its users are stuck with a mate-terminal that doesn't have a really widely used piece of functionality for approximately a year, which is the MATE major release cadence.

I am happy to help out in any additional way I can, please just let me know.
Comment by Brad Fanella (cesura) - Monday, 11 May 2020, 06:11 GMT
Thank you for your effort into this issue, and apologies for not getting around to this earlier. The new release, mate-terminal-1.24.0-2, seems to resolve the URL highlighting issue, although I still seem to have problems with the search functionality. Could you update and confirm this as well?
Comment by Jonas Witschel (diabonas) - Monday, 11 May 2020, 09:18 GMT
Regarding the search functionality, there is a separate pull request ( https://github.com/mate-desktop/mate-terminal/pull/332 , https://github.com/mate-desktop/mate-terminal/commit/9d128954c0e60b6cd8a10a55a243a070fc780fd8 ) by the same author that claims to make it work with VTE 0.60.
Comment by Chris Lea (chrislea) - Monday, 11 May 2020, 19:08 GMT
Oops. For some reason, I thought that the initial patch covered both of those issues. I can confirm that the second patch is needed to fix the search functionality.

I have attached a third PKGBUILD that applies both patches. It also bumps pkgrel to 3. I have confirmed that both URL highlighting and search are working on the build that results from this PKDBUILD file. @cesura if you could please double check to make sure I'm not crazy and then push this into the repos we'd appreciate it. Thanks!
   PKGBUILD (1.3 KiB)
Comment by Chris Lea (chrislea) - Thursday, 14 May 2020, 17:53 GMT
Partially for fun but mostly because I'm rather a pedant, I've made yet another PKGBUILD file for this. It is functionally identical to the previous one but has three changes. First I cleaned up some whitespace. Second I added myself as a contributor in case anybody ever needs to get ahold of me (please feel free to remove this if that's not something that should be in there). Third and most important, I added comments that indicate what the patches actually do, link to the upstream issues on GitHub, and have a TODO to remove the patches when an actual new release comes out that has the fixes included.
   PKGBUILD (2.2 KiB)
Comment by Alejandro Perez (alejandro.perez) - Thursday, 14 May 2020, 19:51 GMT
That worked nicely, thanks @chrislea!
Comment by Alejandro Perez (alejandro.perez) - Tuesday, 26 May 2020, 06:28 GMT
Please, apply second patch from @chrislea.
Thanks
Comment by Chris Lea (chrislea) - Friday, 14 August 2020, 05:12 GMT
Bump on this as a reminder there's a second patch that needs to be applied.

Loading...