Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65780 - [gnome-shell] failure on logging in to my GNOME desktop

Attached to Project: Arch Linux
Opened by Bart Willems (hersenbeuker) - Wednesday, 11 March 2020, 10:20 GMT
Last edited by freswa (frederik) - Sunday, 13 September 2020, 15:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

After running a full system update, I can't login to my GNOME desktop anymore.
Logging in on wayland just brings me back to GDM, whilst Xorg shows me an error screen without details.

I created an additional account on my system and that one can login without issues.

Additional info:

It appears that I'm not the only one with the issue: https://www.reddit.com/r/archlinux/comments/fgikow/new_gnomeshell_indirectly_depends_on_python2/

Running "journalctl -u gdm" gives me the following log entries:
* gdm-password: gkr-pam: unable to locate daemon control file
* gdm: GdmDisplay: Session never registered, failing
* gdm: Tried to look up non-existent conversation gdm-launch-environment
* gdm: Freeing conversation 'gdm-launch-environment' with active job

It might be related to this issue: https://bugzilla.redhat.com/show_bug.cgi?id=1796544

Steps to reproduce:
* have an existing gnome 3.34 system
* run a system update
* try to login with an existing account
This task depends upon

Closed by  freswa (frederik)
Sunday, 13 September 2020, 15:51 GMT
Reason for closing:  Not a bug
Comment by Andrii Zymohliad (azymohliad) - Wednesday, 11 March 2020, 13:16 GMT
I have the same issue. Though it appeared only after today's update. Everything was fine right after gnome 3.36 first release 2 days ago. Rolling back my whole system doesn't help (even to March 3 with gnome 3.34)
Comment by Bart Willems (hersenbeuker) - Wednesday, 11 March 2020, 21:41 GMT
After searching for a long time, renaming ~/.local/share to ~/.local/share_old fixed the issue, I don't know which file/folder inside of the share folder causes the issue though
Comment by Andrii Zymohliad (azymohliad) - Thursday, 12 March 2020, 09:10 GMT
Thanks a lot, Bart! I narrowed it down to ~/.local/share/gnome-shell (renaming it to gnome-shell.bak fixed the login for me)
Comment by Christian Hesse (eworm) - Thursday, 12 March 2020, 09:51 GMT
So this is an issue with gnome-shell?
Can we just close this or do we want to reassign the issue to the gnome-shell maintainer (heftig)?
Comment by Bart Willems (hersenbeuker) - Thursday, 12 March 2020, 09:57 GMT
It seems to be gnome-shell yeah, I wouldn't close it yet, as it requires manual intervention and there are no logs indicating what could be the issue.
So reassigning might be better.
Comment by Ma Jiehong (jiehong) - Friday, 20 March 2020, 19:55 GMT
So, extensions can break gnome-shell with poor logs.

For me, dash-to-dock (https://extensions.gnome.org/extension/307/dash-to-dock/) was blocking everything.
Removing it was enough to fix it.

I opened a bug upstream: https://gitlab.gnome.org/GNOME/gnome-shell/issues/2456
Comment by Gabriel Aumala (GAumala) - Thursday, 26 March 2020, 20:12 GMT
I also had this issue a few days ago when updating gnome from 3.34 to 3.36. I tried deleting local extension data, replacing gdm with lightdm and even completely reinstalling gnome but nothing worked.

Rolling back to March 04 was the only solution that worked for me.
Comment by Daniel McMillan (Nerdrock) - Saturday, 25 April 2020, 15:38 GMT
I have the same issue. Oddly it was with a new user that I created via useradd commandline, there is no .local/share folder in that user's home folder so I'm not sure if it's the same issue or not. I can log in fine with another user that was created during installation.

Comment by Arthur Widetschek (Arthur_W) - Friday, 08 May 2020, 08:45 GMT
same to me. Arch repro from 04-30-2020 works fine. But after upgrade i cannot login. move .local/share had no effects
Comment by Arthur Widetschek (Arthur_W) - Tuesday, 12 May 2020, 10:09 GMT
Upgrade today fixed my problem.

Loading...