Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65765 - [noto-fonts-emoji] fontconfig file causes digits to use emoji font in okteta (and others)

Attached to Project: Arch Linux
Opened by Paul Gideon Dann (giddie) - Tuesday, 10 March 2020, 10:03 GMT
Last edited by Antonio Rojas (arojas) - Friday, 13 March 2020, 10:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With noto-fonts-emoji installed, Okteta (and e.g. kwrite) render digits using the emoji font, resulting in inconsistent font style and spacing. See attached files for the difference between Okteta with the 66-noto-color-emoji.conf file vs without the file.

package version(s): 20191016-4

Workaround is to remove 66-noto-color-emoji.conf file, and install the fontconfig-emoji-git package from AUR, which has fontconfig files that enable noto emojis without causing this issue.
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 13 March 2020, 10:10 GMT
Reason for closing:  Works for me
Comment by Antonio Rojas (arojas) - Tuesday, 10 March 2020, 11:50 GMT
What monospace font is set in systemsettings?
Comment by Paul Gideon Dann (giddie) - Tuesday, 10 March 2020, 11:53 GMT
Bitstream Vera Sans 9pt
Comment by Paul Gideon Dann (giddie) - Tuesday, 10 March 2020, 14:50 GMT
Setting the monospace font to Noto Monospace in SystemSettings also works around the problem (good enough for me for now), but seems too fragile to be a proper solution to this.
Comment by Antonio Rojas (arojas) - Tuesday, 10 March 2020, 20:22 GMT
I can't reproduce this. Do you have any custom fontconfig font file?
Comment by Paul Gideon Dann (giddie) - Friday, 13 March 2020, 10:05 GMT
Hmm, yeah that's weird. This might be a KDE thing. It seems that once I change the Monospace font in System Settings, even if I switch it back to Bitstream Vera Sans again afterwards, the problem goes away. The same thing happened on another machine too. I guess this was some old config that hadn't been updated for a while - I haven't re-installed in 8 or 9 years now :p I can't see anything obviously different in ~/.config/fontconfig or /etc/fonts/conf.d, though.

Oh well, close this as un-reproduceable, I guess?

Loading...