Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#65763 - Using shell commands in XferCommand fails

Attached to Project: Pacman
Opened by Chigozirim Chukwu (FirstAirBender) - Tuesday, 10 March 2020, 04:26 GMT
Last edited by Allan McRae (Allan) - Saturday, 02 May 2020, 04:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
See: https://stackoverflow.com/questions/59538492/pacman-xfercommand-not-working-with-echo-and-aria2

The section for pacman Tips and Tricks mentions a way to use aria2 as a download tool for pacman. However, one of the alternative ways shows how to run the echo command first and then run aria2, but this does not work.

https://wiki.archlinux.org/index.php/Pacman/Tips_and_tricks#aria2

Additional info:
* package version(s)
pacman v5.2.1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
Use the alternative configuration listed here: https://bbs.archlinux.org/viewtopic.php?pid=1491879#p1491879
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 02 May 2020, 04:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Working as intended
Comment by Eli Schwartz (eschwartz) - Wednesday, 25 March 2020, 20:07 GMT
https://git.archlinux.org/pacman.git/commit/?id=808a4f15ce82d2ed7eeb06de73d0f313620558ee

This field is no longer interpreted as a system(2) command to be run in a shell, please use a wrapper script like /usr/local/bin/pacman-xfer-aria2-helper which performs the echo in question. Or this should work:

XferCommand = /bin/sh -c 'set -x; "$@"' _ aria2c --conf-path=/etc/pacman-aria2.conf %u

...

Do you really need the echo?

Loading...