Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65760 - [gnome-control-center] GNOME 3.36.0-1 Privacy options not working

Attached to Project: Arch Linux
Opened by Britt Yazel (brittyazel) - Monday, 09 March 2020, 22:35 GMT
Last edited by freswa (frederik) - Tuesday, 10 March 2020, 01:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Introduced in GNOME 3.36 are granular privacy settings to control which apps have access to Location Services, Camera, and Microphone. However, at least in package gnome-control-center 3.36.0-1, these settings appear to do nothing. If I toggle off location services, GNOME Maps and GNOME Weather ignore this and continue to work as normal. Likewise, no apps like Cheese, OBS, Skype, Telegram, etc area asking for Webcam or Mic permission, though all of them are using these services just fine.

I'm not sure if these are meant to be Flatpak specific toggles, though the point still stands. I tried both Flatpak (through flathub) and native ArchLinux variants of all of these packages, and none of them asked for permissions, nor were affected when disabling any of these permissions. So, something appears to not be wired up correctly.
This task depends upon

Closed by  freswa (frederik)
Tuesday, 10 March 2020, 01:28 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Reporter: It appears these settings are only for Flatpak apps using the specific portals, which there are non of atm.

Loading...