Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65733 - [gitlab] db:migrate returns: libre2.so.0: cannot open shared object file

Attached to Project: Community Packages
Opened by Jacob Bang (julemand101) - Saturday, 07 March 2020, 16:35 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 07 March 2020, 19:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Anatol Pomozov (anatolik)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After updating gitlab to version 12.8.2-1 and running the requested command to upgrade the database:
su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled bundle exec rake db:migrate RAILS_ENV=production"

It will fail with the following error:
LoadError: libre2.so.0: cannot open shared object file: No such file or directory - /usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/re2-1.1.1/re2.so

It looks like re2.so is linked to an older version of libre2:
[root@beta re2-1.1.1]# ldd /usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/re2-1.1.1/re2.so
linux-vdso.so.1 (0x00007ffc2d909000)
libruby.so.2.7 => /usr/lib/libruby.so.2.7 (0x00007f9069ce7000)
libre2.so.0 => not found
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f9069afe000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f9069938000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f906991e000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f9069904000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f90698e0000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007f90698d5000)
libgmp.so.10 => /usr/lib/libgmp.so.10 (0x00007f9069834000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f906982f000)
libcrypt.so.1 => /usr/lib/libcrypt.so.1 (0x00007f90697f5000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f90696af000)
/usr/lib64/ld-linux-x86-64.so.2 (0x00007f906a064000)

Since the re2 package does not provide libre2.so.0 but instead libre2.so.6:

[root@beta re2-1.1.1]# pacman -Ql re2
re2 /usr/
re2 /usr/include/
re2 /usr/include/re2/
re2 /usr/include/re2/filtered_re2.h
re2 /usr/include/re2/re2.h
re2 /usr/include/re2/set.h
re2 /usr/include/re2/stringpiece.h
re2 /usr/lib/
re2 /usr/lib/libre2.so
re2 /usr/lib/libre2.so.6
re2 /usr/lib/libre2.so.6.0.0
re2 /usr/lib/pkgconfig/
re2 /usr/lib/pkgconfig/re2.pc
re2 /usr/share/
re2 /usr/share/licenses/
re2 /usr/share/licenses/re2/
re2 /usr/share/licenses/re2/LICENSE

[root@beta re2-1.1.1]# pacman -Q re2 gitlab
re2 1:20200303-1
gitlab 12.8.2-1
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 07 March 2020, 19:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  community/gitlab-12.8.2-2, community-testing/gitlab-12.8.5-2
Comment by Caleb Maclennan (caleb) - Saturday, 07 March 2020, 16:51 GMT
Same problem here. I just came here to report it after failing to find an issue when I searched. It looks like you posted this after I killed by Gitlab server ;-)

I "solved" it by creating a symlink for: libre2.so.0 -> libre2.so.6.0.0

This is clearly not the right long term solution, but amazingly it worked and I got my Gitlab db migrations done and back online.

Since this link worked it might not be that it is built against the wrong version so much as a fat-finger typo somewhere.

Loading...